mdlchine.com - Chime plug-in uses LiveConnect scripting model in their executeScript() function

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
--
enhancement
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Stephen, Unassigned)

Tracking

Details

(Whiteboard: [plugin], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021126

In Communicator 4.7 and 4.8 there was a function
document.PluginName.executeScript which would pass a script to the embedded
window. I used this to generate some pages for use in lectures (not mounted on
web). I find that the most recent versions of these browsers no longer support
this function. I have tried the code fragment:
  //var names="";
  //for(var i in document.<Plugin name>) names += i + ", ";
  //alert(names);
to locate a synonym or alternative but this (I think it was called LiveConnect)
seems to be obselete. As a result I have had to reinstall Communicator 4.8.
Could someone consider putting this feature back please?
Let me know if you need the pages which don't respond in Mozilla but do in
Communicator 4.8.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
reporter: can you please point me to a reference to this function

Comment 2

16 years ago
Does anyone recall how this is supposed to work? Is there any documentation?
Reporter, can you attach a testcase?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Stephen responded back via email:

There appears to be more information on LiveConnect at:
http://www.netscape.com/navigator/v3.0/liveconnect.html

An important clue is given on
http://www.mdlchime.com/chime/release.html
(search for executeScript)

There is also a specific example on the use of executeScript() at:
http://web.inc.bme.hu/~csonka/csg/oktat/www/chime/chimeembed2.html

It may be that executeScript() is built into the plugin. In which case 
I would still like to be able to access it from Mozilla (and not just 
Netscape 4.8).
Assignee: beppe → peterl

Comment 4

16 years ago
Created attachment 107958 [details]
zipped testcase from reporter

Here's a testcase the reporter sent me via mail.

Comment 5

16 years ago
-->punting to Liveconnect for the |executeScript| function, feel free to bounce
back if this is a plugin bug.
Assignee: peterl → rogerl
Component: Plug-ins → Live Connect
QA Contact: shrir → pschwartau

Comment 6

16 years ago
Reassigning to Patrick; will also try to cc Scott Furman on this.
The question seems to be twofold:

1. Was there an executeScript() method that is now deprecated?

2. If so, was it deprecated from the pure LiveConnect API
   between Java and JavaScript, or from the OJI API?


EXAMPLE AT http://web.inc.bme.hu/~csonka/csg/oktat/www/chime/chimeembed2.html:

<!-- this routine toggles the spin using the LiveConnect interface -->
<script language="JavaScript">
function SpinMol(pluginName, executedYet)
{
  if (!executedYet)
  {
    if (spinning)
    {
      document.themol.executeScript("spin false");
      spinning = false;
    }
    else
    {
      document.themol.executeScript("spin");
      spinning = true;
    }
  }
}
spinning = false;
</script>


<!-- the first Chime displays the structure -->
<embed src="surface/1hew.pdb" type="chemical/x-mdl-molfile"
       width="400" height="350" name="themol"
       spiny="80" startspin="false" align="bottom">

<!-- the second is a button that executes the JavaScript routine -->
<embed type="application/x-spt" width=30 height=30
       button=push ButtonCallback=SpinMol>
Assignee: rogerl → beard

Comment 7

16 years ago
cc'ing Evangelism experts; do they recogize the executeScript() method?

1. Was it part of our LiveConnect scripting model for plug-ins in 4.x?
2. Any chance of bringing it back?
3. Or is there an XPConnect method that plug-in users must use now?
As far as I can tell, this is not IE specific (which has execScript) nor NN4. I
think it is the Chime plugin specific function which was exposed via
liveconnect. Aruner knows more about what it takes to bring a NN4 liveconnect
plugin back from the dead.

Comment 9

16 years ago
Yes, I've never heard of their being a generic "executeScript()" function being
defined on plugin instances. This does sound more like a plugin-specific
function that was exposed via the old Java scriptability layer. The plugin needs
to be revised to use the new XPConnect scripting support.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 10

16 years ago
executeScript( ) is being called on the Chime plugin -- there never was at any
point a default "executeScript" that all plugins exposed (via the browser). 
Chime is going to have to be evangelized about ceasing to depend on the JRI|JNI
Bridge and read the following documentation:

1. http://mozilla.org/projects/plugins/scripting-plugins.html
2. http://mozilla.org/projects/plugins/bi-directional-plugin-scripting.html

Note that all of this is now part of the latest documentation on the Netscape
Plugin API:

3. http://devedge.netscape.com/library/manuals/2002/plugin/1.0/

Comment 11

16 years ago
> Chime is going to have to be evangelized about ceasing
> to depend on the JRI|JNI Bridge ...

I'm reopening this to reassign to Evangelism, then -
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 12

16 years ago
Resummarizing and reassigning to Evangelism -
Component: Live Connect → Plugins
Product: Browser → Tech Evangelism
Summary: Browser has no executeScript() function to communicate with a plug-in → Chime plug-in uses LiveConnect scripting model in their executeScript() function
Version: Trunk → unspecified

Comment 13

16 years ago
Setting default owner and QA -
Assignee: beard → aruner
Status: REOPENED → NEW
QA Contact: pschwartau → mgalli
Summary: Chime plug-in uses LiveConnect scripting model in their executeScript() function → mdlchine.com - Chime plug-in uses LiveConnect scripting model in their executeScript() function

Updated

15 years ago
Whiteboard: [plugin]

Comment 14

15 years ago
SPAM: New Components
Assignee: aruner → english-us
Component: Plugins → English US
QA Contact: mgalli → english-us

Comment 15

10 years ago
the testcase is unuseable (for me)

but i've found the method's documentation, which means that it's existance - which is questioned in this thread is now confirmed ;)

http://developer.mozilla.org/en/docs/JS_ExecuteScript

/* i still searching for the bug i'm hitting :) */
404
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en; rv:1.9.0.19) Gecko/2011032020 Camino/2.0.7 (like Firefox/3.0.19)
Status: NEW → RESOLVED
Last Resolved: 16 years ago5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.