Javascript error on a simple page with no html and body tags

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: fbelloso, Assigned: asa)

Tracking

Other Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126

On new version 1.2final, the folowing code "shows" the form without sumbitting
it. On previous versions of Mozilla and IE works fine.

We know that is not HTML compliant, but we report it because we dont know it you
wanted to produce this behaviour.

On the other hand we will fix our code to include <html> and <body> tags to
solve this problems.

-Begin of html code---------------
<div id="loginLayer"
style="postion:absolute;left:0;top:0;background-color:#FF0000; visibility:hidden">
  <form name="logForm" action="/portalJSP/portal/load.jsp" method="post">
    <input type="hidden" name="user" value="fbelloso" />
    <input type="hidden" name="pass" value="paco" />
    <input type="text" name="" size="1" maxlength="1" />
  </form>
</div>				
<script language='javascript'>
  document.logForm.submit();
</script>


Reproducible: Always

Steps to Reproduce:
1.Cut the source code from details field.
2.Put on an HTML file
3.Open the html with Mozilla 1.2final.

Actual Results:  
The form shows without submitting it

Expected Results:  
To submit the form like previous versions.

<div id="loginLayer"
style="postion:absolute;left:0;top:0;background-color:#FF0000; visibility:hidden">
  <form name="logForm" action="/portalJSP/portal/load.jsp" method="post">
    <input type="hidden" name="user" value="fbelloso" />
    <input type="hidden" name="pass" value="paco" />
    <input type="text" name="" size="1" maxlength="1" />
  </form>
</div>				
<script language='javascript'>
  document.logForm.submit();
</script>
I have tested that this bug was an instance of bug 182500 / bug 182253 based on
comparison of two Linux builds compiled with gcc 3.2.  This bug was present in
the 1.2 release and was the only bug fixed in the 1.2.1 release (and the reason
for the 1.2.1 release).

Marking this bug as fixed since it should be fixed in the 1.2.1 release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.