Closed Bug 182512 Opened 18 years ago Closed 18 years ago

Charts over time broken

Categories

(Bugzilla :: Reporting/Charting, defect, P3)

2.17.1
x86
Other
defect

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: bugreport, Assigned: gerv)

Details

Attachments

(1 file)

2 problems in 2.17.1

1) On product -All-, it gives an access denied error

2) On smaller charts, the chart comes up blank.


Checking for              GD (v1.20)   ok: found v1.38
Checking for     Chart::Base (v0.99)   ok: found v0.99
Checking for     XML::Parser (any)     ok: found v2.31
Checking for       GD::Graph (any)     ok: found v1.35
Checking for GD::Text::Align (any)     ok: found v1
WFM on b.m.o; you will need to give more information.

Gerv
This is on tip.  
I still have not figured out why this is.  It looks like "-All-" needs to be
handled specially.

Attachment #107747 - Flags: review?(gerv)
I'll fix the clear problem
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18
Comment on attachment 107747 [details] [diff] [review]
Patch for the obvious problem

Looks fine to me. r=gerv. But I still need more details on "On smaller
charts..."

Gerv
Attachment #107747 - Flags: review?(gerv) → review+
This change is a regression where the loss of the GroupExists() logic caused
-All- to be treated as a product for which the user has no permissions.

The second matter is something that seems not to effect all sites.  If I ask for
a chart for anything other than -All-, I get a blank chart.  The culprit for
that seems to be either that I don't have support for GIFs and the charting
package is trying to use them or that GD::Image is now required and not checked
by setup.  I get an error....
Can't locate object method "gif" via package "GD::Image" (perhaps you forgot to
load "GD::Image"?) at /usr/bonsaitools/lib/perl5/site_perl/5.6.1/Chart/Base.pm l
ine 167.            
in the webserver's error_log.

I tried loading GD::Image from CPAN, but it does not seem the be a distinct
installation.  Could this be yet another dependency on the version of GD?

Flags: approval?
For the other problem, it seems that the GD upgrade that makes it possible to
use the new charting stuff breaks the old charting used for the charts over time.

This no longer works even on 2.16.1

Since the new charting stuff does work just fine on both these sites, I think I
will wait and see how Gerv's new charting over time works. That is what I really
need anyway.

Yes; GD 1.19 was the last one to support GIF; we now need 1.20 or above.
However, the charts over time should use PNG if they can't use GIF, so there is
a problem here if they aren't.

Gerv
True, though I tried forcing it to "png" and it did not help.

Flags: approval? → approval+

Checking in reports.cgi;
/cvsroot/mozilla/webtools/bugzilla/reports.cgi,v  <--  reports.cgi
new revision: 1.63; previous revision: 1.62
done                     
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Well, they work on b.m.o., so they are obviously not broken for everyone.

Myk: what versions of GD and Chart::Base does b.m.o. have?

Gerv
GD 1.32, Chart::Base 0.99
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.