sserver.sourceforge.net - improper use of :hover affects page background

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English Other
P4
minor
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: James Helferty, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021127
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021127

The page background is supposed to be solid green.  However, the background will
turn white if the mouse is at all moved over the page.  Placing the mouse cursor
elsewhere on the screen (ie; over one of Mozilla's menus) causes the page to
show up as normal.

Reproducible: Always

Steps to Reproduce:
1. Load given webpage
2. Move mouse cursor off the page, then back on.


Actual Results:  
The green border on the page turns white.

Expected Results:  
The border should've stayed green.

Comment 1

15 years ago
Seeing this with 2002112804, Win 98.
This is not Layout, perhaps GFX Compositor?
Status: UNCONFIRMED → NEW
Component: Layout → GFX Compositor
Ever confirmed: true
OS: Windows 2000 → All

Comment 2

15 years ago
Oops...
Assignee: other → kmcclusk
You have in your stylesheet <http://sserver.sourceforge.net/Templates/style.css>
the following rule:

:hover {color: white; background: transparent;} /* when mouse is over link */

The pseudo-class ':hover' applies now to all elements, as you have not specified
any specific element to apply the hover effect on. You probably meant to say

A:hover { color: white; background: transparent;} /* when mouse is over link */

to restrict the hover effect to the 'A' element only since you mention the word
'link' in the comment.

In short, you get what you ask for.

I'd say this report is INVALID.

Comment 4

15 years ago
Not invalid, a TE bug.
Assignee: kmcclusk → momoi
Severity: normal → minor
Component: GFX Compositor → English: Non-US
Priority: -- → P4
Product: Browser → Tech Evangelism
QA Contact: ian → jeesun
Summary: Page background turns white when mouse is over it. → sserver.sourceforge.net - improper use of :hover affects page background
Version: Trunk → unspecified
The reported site's CSS has been fixed to use 'a:hover' instead of ':hover', so
Kat can resolve this one.

Comment 6

15 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jeesun → english-other
fixed
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.