Closed Bug 1825186 Opened 1 year ago Closed 1 year ago

thimbleberry WebGPU demo doesn't work yet on firefox

Categories

(Core :: Graphics: WebGPU, defect)

Firefox 113
defect

Tracking

()

RESOLVED DUPLICATE of bug 1814091

People

(Reporter: bugz, Unassigned)

Details

Steps to reproduce:

visited https://thimbleberry.dev with 113.0a1 on windows. The demo fails quickly, due to #1814091 (getPreferredCanvasFormat).

Beyond that, I hope the demo will be a useful test case. The demo uses WebGPU features including external textures, a cascade of 6+ compute and render passes per frame, optional performance tracking via timestampWrites, etc.

Actual results:

No transformed image appears on the right side.

Expected results:

works in chrome canary.

The Bugbug bot thinks this bug should belong to the 'Core::Graphics: WebGPU' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Graphics: WebGPU
Product: Firefox → Core

You're right; this is basically a dupe of bug 1814091. I'll mark this as a duplicate for now. If we need the debug info you've provided, it should be indexed in that bug. I'll add you to the CC list of that bug.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1814091
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.