QuickLaunch Restarts Itself When Browser Closed

VERIFIED DUPLICATE of bug 149408

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
VERIFIED DUPLICATE of bug 149408
15 years ago
5 years ago

People

(Reporter: Dave Lindquist, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

The QuickLaunch tool, whenever the last open Mozilla component is closed, shuts
down and reloads.  This is extremely inconvenient, because it means a wait of at
least 5->10 seconds before you can use *any* Mozilla components again.

The whole point of QuickLaunch is to keep components in memory instead of
reloading them all the time, which is defeated by this bug.

Both Mozilla 1.1 and 1.2 suffer from this bug.

Of course, we could just rename the tool "VerySlowLaunch" ;-)

Reproducible: Always

Steps to Reproduce:
1. Ensure you are using QuickLaunch mode.
2. Open a Mozilla browser window.
3. Ensure no other Mozilla components/windows are open.
4. Close the Mozilla browser window.

Actual Results:  
The QuickLaunch icon goes away for a couple seconds, then comes back but is
loading for a few seconds more.  During this time, you cannot run any Mozilla
component (all attempts to open mozilla from shortcut icons/etc are completely
ignored).  Even attempts to open Mozilla from the quick launch menu are ignored
while it is still "loading" (when the "Exit Mozilla" is no longer grayed out,
the "loading" is done and you can actually open a Mozilla component).

Expected Results:  
Don't have the "QuickLaunch" ever close!  It should simply stay resident, and
thus I would be able to load another Mozilla window immediately.

While there is no crash or functional impairment, and the "workaround" is to
simply wait for it to come back, the annoyance/impatience factor is high enough
to warrant, IMO, a "normal" priority.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 149408 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
This is also mentioned in the release notes:

http://www.mozilla.org/releases/mozilla1.2/#quicklaunch

Verifying duplicate.
Status: RESOLVED → VERIFIED
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.