Closed Bug 1825265 Opened 11 months ago Closed 9 months ago

Message list treeview not updated for new messages until scroll/mouseover event

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED DUPLICATE of bug 1821988
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: leofiore, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/111.0

Steps to reproduce:

  1. open thunderbird
  2. set Layout > Wide View
  3. on the inbox folder, show message list as threaded using the toggle button on the grid
  4. wait for new messages to be sent as reply for already existent threads

Actual results:

when new mail arrives, or whenever a message is deleted, or read, the message list remains unchanged until a mouse event is fired: when the mouse hovers a message row, it is updated with the correct entry, but the remaining rows are unchanged. The same rows can be found in the wrong position, misplaced, or doubled. If the message list is scrolled down, it is redrawn correctly

Expected results:

message list and threads should be updated automatically after every event like new mail arrival and deletion

Blocks: sn-msglist
Keywords: regression
Summary: Message list treeview not updated until scroll/mouseover event → Message list treeview not updated for new messages until scroll/mouseover event
Whiteboard: [Supernova]

This was intermittent for me on openSuse in 112, now hardly ever updated in 113.0b1, but did not update on scroll/mouseover but required clicking on the folder to change the new mail display status.

Folder updates were working fine in 110.0b1, working in 112.0b7 although seemed not to be as responsive and not working in 113.0b1.

Whiteboard: [Supernova] → [Supernova3p]
Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Duplicate of bug: 1821988
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.