Closed Bug 182553 Opened 17 years ago Closed 17 years ago

Copypasting large text/html targetdata fails in Composer

Categories

(SeaMonkey :: Composer, defect, major)

All
Linux
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 56219

People

(Reporter: me, Unassigned)

Details

User-Agent:       Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916
Build Identifier: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

I am creating a Clipboard Management tool for GNOME. It is called GNOME
Clipboard Manager aka gcm (gcm.sf.net). While all other applications, like
Evolution Composer when HTML formatting is on and OpenOffice.org, seem to work
with my manager; Mozilla composer only works when the text/html target is rather
small. The mozilla browser gives the text/html target perfectly; so that is not
the problem .. it is the composer who does not want to parse or receive the
text/html data when this target is large and comes from a non-Mozilla Window.

So.. what works :

Copy in Mozilla browser
-> My manager will automaticly fetch ALL targets and store them at this point 
-> My manager has claimer selectionownership for ALL those targets
-> My manager is ready to give the text/html target and does this perfectly
Paste in OpenOffice.org
Paste the text/html target in Evolution Composer

What does not work
Paste in Mozilla Composer

That does work :
Turn off my manager
Copy in Mozilla browser
Paste in Mozilla composer

I guess that Mozilla browser and Composer do some internal communication when
the text/html target is to large. It should not if that is the case imho. That
way external applications cannot feed the composer text/html data. Examples are
OpenOffice.org and the Evolution E-mail Composer.

Reproducible: Always

Steps to Reproduce:
0. Start my Clipboard Manager which automaticly fetches all targets of a new
selection, stores them and automaticly claims ownership on those fetched
targets. The manager really is ready to deliver it's data (like the text/html
target) - this has been tested very well
1. Copy in Mozilla
2. (my manager does it's stuff here)
3. Paste in Composer

Actual Results:  
Composer waits a few seconds; and then just stops (it does not hang or crash, it
just does not paste the text/html data. WHILE other applications; like Evolution
composer and OpenOffice.org DO paste the data ALSO when it is coming from my
manager).

Note that small pieces of text/html data DOES work in Mozilla Composer too. It
is only when the selected text in Mozilla is rather large!


Expected Results:  
It should paste the data ! :-) nomather how big it is and from which
application/Window it comes.

Feel free to checkout http://gcm.sourceforge.net for the project (the manager)
if you want to test with my clipboard manager. I am pretty sure, however, that
you can simulate this by writing a small application that claims ownership over
a selection that contains a large text/html target... and then try pasting that
data in Mozilla Composer
Btw. For testing I dod the following too :

Copy a large piece of html-formated text in mozilla. Pasted it to Evolution
Composer. Then I selected all text in Evolution Composer and then coptied that
selected text.
Then I opened the Mozilla Composer and I tried pasting : this failed.

Then I started my manager, copied the large text from Evolution Composer; my
manager fetched all the targets; I closed the Composer window and started
writing a new mail; set the formatting to HTML and then pasted in Evolution
Composer (so now my manager is the source) : this did worked perfectly.

Same happens with OpenOffice.org and large text/html targets. Mozilla Composer
just refuses to accept larger text/html targets .. other applications take the
data and work.

So I can reproduce this problem without using my clipboard manager... for
example between Evolution Composer and Mozilla Composer I can make Mozilla
Composer fail pasting the contents.
I think the limit is at 4000 bytes. Resolving as dup of bug 56219.

*** This bug has been marked as a duplicate of 56219 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
reset owner in case bugs are reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.