Closed Bug 182573 Opened 18 years ago Closed 12 years ago

Mozilla PalmSync Install failure message "Error in loading the Conduit Manager" [suite]

Categories

(MailNews Core Graveyard :: Palm Sync, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: mozilla, Unassigned)

References

Details

(Whiteboard: comment 7 is effective work around for some)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

HotSync Manager is not loaded.
When trying to install "Address Book Palm Sync Install" a pop up window writes:
"Error in loading the Conduit Manager while installing the Mozilla Address Book
Palm Sync Conduit" with an "OK" button.
The conduit can't be installed.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
I get exactly the same error with and without the HotSync manager loaded.
I am using Palm Desktop 4.1

Since I upgraded from Moz 1.1, I did a complete reinstall of both Mozilla and
the Palm desktop in different orders (i.e. reinstall Palm 1st, Moz 2nd and vice
versa) and it made no difference.
To enable Palm sync you need 2 files which are redistributable by Palm. However,
Mozilla can not redistribute them since they are not open source. 

We figured out that in 60-65% cases a registry key exists on user's machine who
have the Palm software installed on their machines. This registry key provides
the path to these 2 Palm files. So you need this registry key in your system. 

A registry file for this key is attached on the meta bug:
http://bugzilla.mozilla.org/attachment.cgi?id=104819&action=view. 
You will need to edit it and specify the path in there to point to the directory
where your Palm files are installed. Once you have done that just double click
the file from Windows Explorer, it will register your path. 

Then go ahead and click on the Windows /Start / Programs / Mozilla / Address
Book Palm Sync Install. This should ask for confirmation to enable Mozilla AB
Palm Sync. Click "Yes" and you should see a success message.

Once you have done that you can connect your Palm device and hit the HotSync
button on your Palm cradle. This should bring up the HotSync Manager dialog on
your desktop and should start Mozilla. Once sync is complete, close Mozilla and
then restart it and open Mozilla Address Book to verify the sync.
The above has also been documented in the 1.2 release notes and you can download
the registry file from the mozilla web site. Here are the install instructions
which also talks about this registry stuff:

http://www.mozilla.org/releases/mozilla1.2/#palminstall
After fixing this problem you have to see bug #182405 for changing the wrong
name displayed as conduit name.
Severity: major → normal
QA Contact: meehansqa → nbaca
The Address Book Palm Sync Install fails for 1.3 even with the registry 
entries set as per attachement.  I did a complete uninstall of 1.2.1 before 
installing 1.3 and am now unable to reinstall the address book conduit for 
mozilla<=>palm.

And yet, my paths in the registry do point to the correct locations (where 
palm is installed :-)
The same applies to me (Windows 2000 user with three different accounts, Mozilla
1.3 and Palm OS 4.1). The palm sync fails. I get the error message: "Error
loading the conduit Manager while installing the Mozilla Address Book Palm Sync
conduit". I have added the said regestry key to regedit. But it still fails.
I wonder if this has something to do with Windows 2000 user accounts. In Windows
2000 I had to install the palm OS twice, First for user 1 (working at home from
account 1) and second for user 2 (working in the office from within account 2).
The Palm OS can clearly distiguish between these two users and even synchronize
them. It clearly synchronizes to different directories (user 1 and user 2
directories) on my laptop. However, the regedit key provided above does not go
into HKEY_CURRENT_USER but goes into HKEY_LOCAL_MACHINE. So how could he find
the right palm.exe file if this has been installed twice for a different user
account?

Juerg
I had the same issue.  The registry key didn't fix it for me either, but the 
following works: get a DOS prompt.  Go to your Mozilla install directory 
("C:\program files\mozilla.org\mozilla" for me) and run the following:

PATH=C:\Palm;%PATH%
palmsyncinstall

That worked.  It'd be nice to fix the bug, but this seems to be a reasonable 
workaround.
Workaround works for me. I had the same problem.
Thanks Oliver Dain, your workaround solved the synchronization issue.

Juerg
I made the registry changes to no avail but the

PATH=C:\Palm;%PATH%
palmsyncinstall

fixed it - eventually.  Not before Mozilla came up with a series of runtime errors:

Program: D:\PROGRA~1\mozilla.org\Mozilla\Mozilla.exe

R6025
- pure virtual function call.

Looks like someone may have done an unsafe cast.

This error kept popping up until I killed Mozilla.  The next HotSync worked.

A couple of other items.  I WAS able to install the AB Palm Sync from the
Administrator account, but no matter what I did I wasn't able to do it for my
normal account.  Until this work around did it.

This really was very annoying and caused me a lot of time.  This work around
needs to be advertised as much as the registry edit fix!
I just upgraded to 1.5rc2 from 1.4 and my previously working PalmSync conduit
stopped working.  It deinstalled fine but upon reinstallation I keep getting the
message 
"Failed to register the Mozilla's Palm Sync Support Proxy Dll while installing
the Mozilla Address Book Palm Sync Conduit"

I reinstalled my Palm Desktop 4.01 to see if that helped (no). And now I am a
little stumped and just a little annoyed since it was working fine before.
*** Bug 193679 has been marked as a duplicate of this bug. ***
User may want to change sync options to force desktop to overwrite pda - after
performing the above fix, the only record brought over was one that I had
updated earlier in the day.

With Palm sw, this is accomplished by doing:
palm> HotSync -> Custom... -> Mozilla Address Book : desktop overwrites palm
	Realize that this is a 1 time setting unless default is selected
I tried this already.  Did not help.  The initial sync works but no subsequent 
syncs whether Palm to Mozilla address book or Mozilla address book to Palm.

I regretfully cannot convert over to Mozilla if the Palm sync does not work 
correctly... though I really, really want to...  I have been struggling with 
this same bug since Mozilla 1.2 (tried 1.2, 1.3, 1.4, 1.5 and 1.7b) and have 
been trying it with different Palm branded units with different OSes (W2K and 
XP).  

I REALLY look forward to your fixing this.

> User may want to change sync options to force desktop to overwrite pda - after
> performing the above fix, the only record brought over was one that I had
> updated earlier in the day.

> With Palm sw, this is accomplished by doing:
> palm> HotSync -> Custom... -> Mozilla Address Book : desktop overwrites palm
>         Realize that this is a 1 time setting unless default is selected
Product: MailNews → Core
I do not even get a  Address Book Palm Sync Install (in my
Start/Programs/Thunderbird options!
I do not even get a  Address Book Palm Sync Install (in my
Start/Programs/Thunderbird options!
*** Bug 223258 has been marked as a duplicate of this bug. ***
Severity: normal → major
Whiteboard: comment 7 is effective work around for some
(just to be clear, no one is working on this, AFAIK)
Assignee: rdayal → nobody
QA Contact: nbaca
this is *not* palm sync extension - it the older sync program.
QA Contact: vseerror
Summary: Mozilla PalmSync Install failure → Mozilla PalmSync Install failure message "Error in loading the Conduit Manager"
*** Bug 240833 has been marked as a duplicate of this bug. ***
In reply to Michael Smitreski comment #16:
> I do not even get a  Address Book Palm Sync Install (in my
> Start/Programs/Thunderbird options!

For Thunderbird you want the extension for Thunderbird. See the palmsync link at http://kb.mozillazine.org/Category:Address_Book_%28Thunderbird%29 

(Mozilla suite and now Seamonkey has an entry in Start/Programs/... - but not Thunderbird.)  


In reply to Michael Baraz comment #14:
> I tried this already.  Did not help.  The initial sync works but no subsequent 
> syncs whether Palm to Mozilla address book or Mozilla address book to Palm.

have you tried the latest 1.x release http://www.mozilla.org/releases/
This bug is for legacy SUITE and Seamonkey where palmsync is installed via 

   Start -> Programs -> Mozilla -> Palm Tools -> Address Book Palm Sync Install


This works for me. Will give a few more days and if no one responds then marking and closing as WFM.   Michael (Michael.Baraz@AIMWebWorks.com)?
Summary: Mozilla PalmSync Install failure message "Error in loading the Conduit Manager" → Mozilla PalmSync Install failure message "Error in loading the Conduit Manager" [suite]
Depends on: 434745
I got a couple emails on this bug in the last couple weeks. I was hoping to see this problem was being taken seriously. Not. Thunderbird works great when it works... but it doesn't work often enough to call it a stable product. The lack of a Palm sync had me maintaining two address books... too much effort. I have finally given in and gone to the dark side. The Outlook conduit works perfectly. Nor have I had to delete my index files or reindex my inbox. I still love Thunderbird but realized we can't live together any more.
Michael, Thanks for the info. You'll note there are no responses in the bug in over 2 years. Unfortunately it is hard to diagnose a problem without feedback (eg. to comment 21) from those who may be seeing a problem in this bug, or in other Thunderbird bugs.
Assignee: nobody → bienvenu
Product: Core → MailNews Core
Assignee: bienvenu → nobody
QA Contact: vseerror → palmsync
I'm going to say WONTFIX, given this is for releases which are no longer supported, and all of these issues either fixed or covered in newer bugs
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.