Status

()

Core
Internationalization
VERIFIED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Mr..VW, Assigned: smontagu)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.2b) Gecko/20021016

I only use the browser in my Intranet, although the IE works good, I want to use
Mozilla instead. I found that Mozilla has a bug! The URL cannot use like this:
<a href=good.php?class=ÄãºÃ> . class cannot be Chinese! 
This bug would make half of Chinese internet site could not use Mozilla!

------ next is Chinese ---ÏÂÃæÊÇͬÒåµÄººÓﱨ¸æ£¬¶Ô²»Æð,ÎÒµÄEÎIJ»Ì«ºÃ,ÅÂŪ´í-----
ÎÒÔÚÎҵľÖÓòÍøÖÐʹÓÃä¯ÀÀÆ÷£¬ËäÈ»IEûÓÐÎÊÌ⣬µ«ÎÒ¸üÏëʹÓÃMozilla¡£ÔÚʹÓÃMozillaʱ
ÎÒ·¢ÏÖÒ»¸öÎÊÌ⣬ÄǾÍÊÇÔÚÁ´½ÓÖв»ÄÜʹÓÃÏó:<a href=good.php?class=ÄãºÃ>µÄÁ´½Ó£¡
classµÄÖµ²»ÄÜʹÓúº×Ö¡£
Õâ¸öÎÊÌ⽫Ôì³É´óÔ¼Ò»°ëµÄÖÐÎÄÍøÕ¾²»ÄܲÉÓÃMozillaÕý³£ä¯ÀÀ¡£

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
->Internationalization.  Please bounce if needed.
Assignee: asa → smontagu
Component: Browser-General → Internationalization
QA Contact: asa → ylong

Comment 2

15 years ago
It sounds like a dup of bug 179026 for me.

Mr..VW:
Please try a latest build to see if you still have the problem? thanks!

ÇëÊÔÊÔÓÃ×îеÄbuild£¬ÎÒÏëÏÖÔÚÓ¦¸ÃûÓÐÎÊÌâÁË¡£
Keywords: intl

Comment 3

15 years ago
On the face of it, this should work with the latest
build particularly after the fix in Bug 179026.
In order to verify that this problem really exists, 
we need a real test case.

Reporter, can you send us a real test case for
this? Or publish it somewhere?

(URL parsing with Chinese parameters seem to be
working OK. If there is a problem with a specific
site, we need to know how exactly this is failing.)

Comment 4

15 years ago
Email sent from reporter:
---------------------------
I had downloaded the latest build of Mozilla, and there are anything is ok! 
Thank you!

I'm marking this as works for me even though in case this a dup of 179026.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 5

15 years ago
Mark as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.