Closed Bug 18262 Opened 20 years ago Closed 20 years ago

Long header for non-ascii chars is showing up as a garbage in the thread pane

Categories

(MailNews Core :: Internationalization, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 18105

People

(Reporter: marina, Assigned: nhottanscp)

Details

Steps to reproduce:
-open new mail;
-type into Subject field a long header with non-ascii chars (8bit);
-send message and get it;
//note: header in the thread is displaying garbled. (it doesn't matter if you
copy /paste a long string from the body into header)
Subject header in the body is correct, caption of the window is fine also.
It looks like something goes wrong when we do MIME encoding for thr header
I have a similar bug 18105 on linux, if they are the same please make one of
them as a dup and make it a cross platform bug.
Also, in order to make sure this is a sending problem, I need two things.
Make sure the header is not viewable in 4.x either.
Paste (or attach) generated subject in the bug report.
In 4.7 this problem is worse; not only thead pane string is a garbage but the
Subject header in the message body has the same problem.Here is the string i
used "léjëkìgëfìrìdï" (copied into the Subject field three times, a nonsense,
just composed with 8-bit chars)
This problem occurs on Win NT4.0
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
This is the same problem as 18105, MIME encoder problem.
Using the data in this bug, I got the same assersion as I had for 18105 on my
debug build.

*** This bug has been marked as a duplicate of 18105 ***
QA Contact: momoi → marina
marina, please verify this.
Status: RESOLVED → VERIFIED
verified as such.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.