-UILocale and -contentLocale options need doesn't work

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: aurel32, Assigned: tao)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021128 Debian/1.2-1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021128 Debian/1.2-1

The options -UILocale and -contentLocale seems to doesn't work, or more
precisely doesn't change the language of *all* Mozilla. It doesn't change the
languages of the menues.

Reproducible: Always

Steps to Reproduce:
1. Install a language pack (for me fr-FR)
2. Start: mozilla -UILocale fr-FR -ContentLocale fr-FR
Actual Results:  
Mozilla is in French, but the menues are still in English.

Expected Results:  
All Mozilla should appears in French.

I have explained the bug when the default language is in English and I want to
switch it to French. The bug is also present when in the preference menu the
selected language is French and I want to start Mozilla in English (in this case
everything but the menues is in English).

Moreover it is not a bug of the French language pack, I am able to reproduce it
with other languages, at least in Mozilla 1.1 (A lot of languages pack are not
yet available for Mozilla 1.2).
To tao. This might be a dupe of bug 91866.
Assignee: smontagu → tao
Summary: -UILocale and -contentLocale options need doesn't work → -UILocale and -contentLocale options need doesn't work
(Reporter)

Comment 2

16 years ago
Yes it seems to look like bug 91866. However the bug 91866 was for windows and
mac only, and moreover, it seems there is no <user
profile>/chrome/user-locales.rdf on Linux architectures.
(Reporter)

Comment 3

15 years ago
Starting with Mozilla 1.4, this problem doesn't appear anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.