file-download of unknown file-types

RESOLVED WONTFIX

Status

SeaMonkey
General
--
enhancement
RESOLVED WONTFIX
16 years ago
14 years ago

People

(Reporter: --, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; de-AT; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; de-AT; rv:1.2) Gecko/20021126

mozilla tries to display unknown file-types as an ascii-type file.

i think, it should be downloaded like eg. a .zip file. IE does so, and i think
this is just the better way.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
The file Type is not unkown. The server means that this is a text/html file.

           => `cpl_wb-finale_mouz-gg-eol_de_nuke.rar'
Resolving www.cs-scene.de... done.
Connecting to www.cs-scene.de[212.227.118.90]:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]

Mozilla can render text/html  and you get the binary output on the screen.
The server is broken and the webmaster must correct the mime-type for this file.
It works in IE because IE is broken.

We can't display this without break the standards. -> wontfix
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.