icons have initial size way too big

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
RESOLVED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Akkana Peck, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When I load a mail folder, I see a few msg header lines load, with room for
great big icons at the left side of each line; then the "envelope" icon loads,
about half the size of the initially specified size, and the lines all reflow
much smaller so I get nearly double the number of headers. Loading would look
much better (less like a mistake) if the initial size of the envelope icon was
specified correctly. Cc'ing cmanske because we had a similar problem at one time
with our toolbar icons, and he may remember whether the fix was CSS or XUL. (I
want this to be component Front End, but that isn't working from mozilla!)

Comment 1

18 years ago
These are the icons used in the "folder tree"?
Are we really reusing larger icons that have width and height set to resize
them smaller? While that may allow reuse, it's not very efficient and I agree
with Akkana's assesment that it's ugly.
I don't recall doing anything like this in Composer, so I can't help other
than give my "humble opinion" to use icons of the exact size needed in tree
widgets.

Comment 2

18 years ago
no the problem is that titled buttons default to some large fixed size, and I'm
hoping that there's a way with CSS to set a default.... akkana thought you might
have run into this in the toolbars.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M14

Comment 3

18 years ago
It seems to have gotten better lately.  I'm cc'ing hyatt in case he has any
ideas about style rules that might affect this.
(Reporter)

Comment 4

18 years ago
Yes, now the icons have an initial size that's too small rather than too large,
but they still draw at one size then have to reflow when the real icons are
loaded.

(Actually, I like the small size -- wish the real icons were that small so they
wouldn't space the message threads out vertically as much as they do.)

Updated

18 years ago
Target Milestone: M14 → M16

Updated

18 years ago
Target Milestone: M16 → M20

Updated

18 years ago
Target Milestone: M20 → Future

Comment 5

18 years ago
Move to future target milestone for review in a later release.  

Comment 6

16 years ago
Is anyone still seeing this?  There's been a lot of work (most notably the
switch to outliner) since this was filed.  Reassigning to sspitzer
Assignee: putterman → sspitzer
Status: ASSIGNED → NEW

Comment 7

16 years ago
i do not see this bug on Linux (current CVS.)

Updated

15 years ago
QA Contact: lchiang → nobody

Comment 8

14 years ago
WFM and no mention of the bug in four years, -> WFM.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.