FORM submission with GET instead of POST and to itself if the page is missing BODY tags

VERIFIED DUPLICATE of bug 182155

Status

()

VERIFIED DUPLICATE of bug 182155
16 years ago
16 years ago

People

(Reporter: quetzalh, Assigned: alexsavulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

In a form submission (wrong.html)  with only the tags like this:

<form method="POST" action="destiny.php">

Field 1: <input type="text" name="field1" value=""><p>

Field 2: <input type="text" name="field2" value=""><p>

<input type="submit" name="submitButton" value="Test Submit">

</form>

(This is all the source code. no HTML, no HEAD, no BODY tags) 

The page "destiny.php" not receive nothing. The page wrong.html will be receive
the variables to itself with GET method INSTEAD of POST method and in the  the
URL appear somethins like this:

http://webserver/wrong.html?field1=one&field2=two&submitButton=Test+Submit

If you test in "wrong.html" you can see the variables field1 and field2 in $_GET
global array (with php capable server of course)

Tested in

Debian GNU/linux  
Version: Woody
CPU: Pentium IV
Mozilla version: 1.2
Webserver: Apache 1.3.26 (with bugfixes) and php 4.1.2


Reproducible: Always

Steps to Reproduce:
1. Load the "wrong formulary" in the browser
2. Press the submit button


Actual Results:  
the values of the form can be seen in the URL: 
?field1=value1&field2=value2&submit=Submit  If the be passed with POST method no
values will be shown in the URL. I Aditionaly if you test for the $_POST and
$_GET array in some server with php support (wrong.php instead of wrong.html) 
!You will find the values in the $_GET array !



Expected Results:  
The values will be passed TO THE DESTINY SCRIPT and with POST method if the FORM
tag have method=POST  no matter if the page have BODY tags or not

I have a page in  http://quetzalcoatl.org.mx/mozillabug/ to show the bug

Comment 1

16 years ago
I can Confirm this bug with the same 1.2 build on Win32. 

Had a script with malformed html output that kept me in a loop because of this
bug. It taught me to verify the ouutput of my scripts anyway.

(Assignee)

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 182155 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.