Closed Bug 1827257 Opened 1 year ago Closed 1 year ago

Add Move Up/Down options to Folder Mode context menu

Categories

(Thunderbird :: Folder and Message Lists, task)

Tracking

(thunderbird115 fixed)

RESOLVED FIXED
116 Branch
Tracking Status
thunderbird115 --- fixed

People

(Reporter: solange, Assigned: vineet)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(2 files)

Add the options to Move Up/Down if multiple modes are available. If there are no multiple modes active, disable the options.

Depends on: 1827261
No longer blocks: 1827254
Depends on: 1827254
Whiteboard: [supernova]
Whiteboard: [supernova] → [Supernova3p]
Blocks: 1827254
No longer depends on: 1827254
Assignee: solange → vineet

How to Test

  • Ensure you have multiple folder modes selected
  • Click on the options button (3 vertical dots) for a folder mode
  • Select Move Up or Move Down depending on position of the folder mode within your list of folder modes

Comment on attachment 9337542 [details]
Bug 1827257 - Add move up and move down options in context menu for folder modes. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): -
User impact if declined: They will be unable to re-sort the order of their folder modes in the folder pane.
Testing completed (on c-c, etc.): Created a test file, ran a try run, and manually tested the feature.
Risk to taking this patch (and alternatives if risky): It is not risky to uplift this patch.

Attachment #9337542 - Flags: approval-comm-beta?
Status: NEW → ASSIGNED
Target Milestone: --- → 116 Branch

Pushed by elizabeth@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/a6337e6203ee
Add move up and move down options in context menu for folder modes. r=freaktechnik

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9337542 [details]
Bug 1827257 - Add move up and move down options in context menu for folder modes. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9337542 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: