cursor(focus) is not in the "location" bar if Composer was running prior to the Browser start

RESOLVED WORKSFORME

Status

SeaMonkey
Location Bar
RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: Stanislav Polshyn, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

open mozilla Composer
open mozilla Browser
problem:
cursor is not in the "Location" bar

Reproducible: Always

Steps to Reproduce:
1. make sure, there is no open mozilla windows
2. open mozilla Composer
3. open mozilla Browser


Actual Results:  
cursor (focus) is not in the "Location" bar
even worse, it's hard to say where focus is (cause [Tab] pressing does not help
to bring focus anywhere)

Expected Results:  
cursor has to be in the "Location" bar upon Browser start

tried this on work computer (win2000, M 1.2)
and home computer (XP, M 1.2)
with the same results

Comment 1

15 years ago
That goes as well for Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a)
Gecko/20021212.

If anything Mozilla is running when I start the browser, the cursor is not
in the location bar and can't be found anywhere. That's even true if the
only thing that's running is the tray icon.

Comment 2

15 years ago
->URL bar
Assignee: asa → hewitt
Component: Browser-General → URL Bar
QA Contact: asa → claudius

Comment 3

15 years ago
I can confirm that this behavior also happens on Linux. Any time you open a new
Mozilla window from either within Mozilla (ie: File/New/Navigator Window) or
from the OS (ie: click on Mozilla icon) the cursor *should* be in the location
bar. However, in actuality, if there are one or more Mozilla windows already
open, the cursor is not in the Location bar.

This behavior has been in Mozilla for a long time. I just go around to filing a
bug report about it now.

This is EXTREMELY annoying.
WFM on WinXP SP1 trunk 2003081515.

Reporter: could you try this using a recent nightly from
<http://ftp.mozilla.org/pub/mozilla/nightly/latest/> ? If it works, please
resolve this bug as WFM. Thanks !

rcl24@drexel.edu: Do you experience this on Linux using a recent nightly build ?
Whiteboard: DUPEME
(Reporter)

Comment 5

15 years ago
WFM.
Tested this with
nightly build (08/19/03) on Win2000 SP4 and
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529 on WinXP.
It works OK. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.