Need to lazily load the OJI DLL

RESOLVED DUPLICATE of bug 26516

Status

Core Graveyard
Java: Live Connect
P3
normal
RESOLVED DUPLICATE of bug 26516
19 years ago
8 years ago

People

(Reporter: Simon Fraser, Assigned: drapeau)

Tracking

({helpwanted, perf})

Trunk
Future
helpwanted, perf

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm-])

(Reporter)

Description

19 years ago
The OJI DLL gets loaded at startup now by the following call in
nsJSEnvironment::nsJSEnvironment().

  // Initialize LiveConnect.  XXXbe uses GetCID rather than progid
  NS_WITH_SERVICE(nsILiveConnectManager, manager,
                  nsIJVMManager::GetCID(), &rv);

OJI should only be loaded the first time it is needed.

Updated

19 years ago
Assignee: fur → drapeau

Comment 1

19 years ago
I think this is an OJI issue, not a LiveConnect one.  The LiveConnect API was
designed from the start to allow the JVM to load lazily, i.e. at the first
reference to LiveConnect from a script.  (From the viewpoint of LiveConnect, OJI
is just a JVM that wraps around the real JVM, so OJI should be able to load
lazily as well).  I *thought* that Warren got lazy OJI/JVM loading working a
long time ago, but perhaps that was in the MozillaClassic codebase.

Comment 2

19 years ago
Yeah, that was in mozilla classic.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M14
(Assignee)

Comment 3

19 years ago
Will look into this, not for this milestone, though.

Comment 4

19 years ago
Updating QA Contact
QA Contact: cbegle → rginda

Updated

18 years ago
Blocks: 1785

Comment 5

18 years ago
New feature.
Target Milestone: M14 → M30
(Reporter)

Comment 6

18 years ago
This is a *feature* ? Adding perf to the keywords.
Keywords: perf
I changed OS to All.  I don't think this should be M30, either.  Is there any 
hold-up that I can help with?

/be
OS: Mac System 8.5 → All

Comment 8

18 years ago
I agree that this shouldn't be M30 (which used to mean post-FCS). This seems 
like a simple win if someone just spends a few hours to clean it up.

Comment 9

18 years ago
I just discovered bug 26516 which is a dup. Drapeau - can you work with av to 
see who's going to own this?
(Assignee)

Comment 10

18 years ago
Brendan, you can help if you can fix the bug.  Right now, we're trying to get 
security working in OJI and plugins for M16, plus some other bugs.  Just no 
staff to take care of this one right now.

I'll change the milestone date to "Future", which right now reflects the 
accuracy of my ability to predict when this will get fixed.

Warren: I won't be able to work with av on this for another week.  Ed Burns is 
the likely candidate to delve into this, and he's away on business all of this 
week.  If I can get somebody else to look into it this week, I will, but right 
now the other folks are busy on other tasks, so unfortunately I believe it's 
unlikely that I'll be able to determine the proper ownership this week.
Target Milestone: M30 → Future

Comment 11

18 years ago
I really think we should fix this.
Keywords: arch

Updated

18 years ago
Keywords: arch
Any chance this will get fixed for final release?  It's designed to be
lazy-loaded, after all.  Adding helpwanted
Keywords: helpwanted

Comment 13

18 years ago
I don't know how much time this costs during startup, but I'll nominate it for 
RTM, Mozilla 0.9. This should really be fixed...
Whiteboard: [Mozilla0.9] [RTM]
You nominate with keywords (which get spell-checked and are more queryable,
compared to made-up status whiteboard [PseudoKeywords] -- see the roadmap).  I
took the liberty of fixing these.

/be
Keywords: mozilla0.9, rtm
Whiteboard: [Mozilla0.9] [RTM]

Comment 15

18 years ago
rtm-, not stop ship, no patch.
Whiteboard: [rtm-]

Comment 16

18 years ago
Adding this bug to startup performance tracker bug 7251
Blocks: 7251

Comment 17

18 years ago
This is a dup of bug 26516.  This bug has some valuable status though.

*** This bug has been marked as a duplicate of 26516 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
No longer blocks: 7251

Updated

8 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.