Auto-repeat not ignored for shortcuts

VERIFIED WONTFIX

Status

--
trivial
VERIFIED WONTFIX
16 years ago
16 years ago

People

(Reporter: stf, Assigned: bryner)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021128 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021128 Chimera/0.6+

http://developer.apple.com/techpubs/macosx/Essentials/AquaHIGuidelines/AHIGUserInput/Type_Ahead__Auto_Repeat.html
When a character key is held down for a certain amount of time, it starts
repeating automatically. The user can make adjustments to this feature, called
auto-repeat, in Keyboard preferences.

An application can tell whether keystrokes are generated by auto-repeat or by
the same key being pressed numerous times. Your application can disregard
auto-repeat keystrokes; it should IGNORE them in keyboard equivalents.

Reproducible: Always

Steps to Reproduce:
1. Open a New Window
2. Hold down Cmd-T
Actual Results:  
Non stop (<17) creation of Tabs.

Expected Results:  
Ignore the auto-repeat.

Comment 1

16 years ago
This also happens opening new windows in Chimera/2002112604. Both new windows
and tabs continuously open in FizzillaMach/2002112607 as well. But, new windows
also continuously open in Apple's own TextEdit, though not in the Finder.

Comment 2

16 years ago
I guess that since the HIG says "Your application can disregard auto-repeat
keystrokes; it should ignore them in keyboard equivalents." that chimera should
ignore them.

Comment 3

16 years ago
Okay, I'll confirm this. These key commands need to not auto-repeat in either
Chimera or Mozilla.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
Command keys auto-repeat in all Cocoa apps that I tried (e.g. iCal). This is a
Cocoa problem, not our problem.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
v wf.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.