Location field accepts strange and illegal characters

RESOLVED WORKSFORME

Status

Camino Graveyard
Location Bar & Autocomplete
--
minor
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Stephane Moureau, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.6
PowerPC
Mac OS X

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021128 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021128 Chimera/0.6+

By using the CTRL key and various keys, you can enter very strange characters
but everything is accepted.
I think it has something to do with some unix shortcut to enter special
characters (Ctrl-Q or A/E). Someone who knows those shortcut could probably
explain this better than me.

Reproducible: Always

Steps to Reproduce:
1. Type CTRL-Q inside Location Field
2. Then CTRL-S

Comment 1

16 years ago
WorksForMe in Chimera 2002112504. Typing CTRL-Q CTRL-S in the Location field has
no effect for me.
(Reporter)

Comment 2

16 years ago
I'm on a french keyboard tab azerty / capslock qsdf / shift <wxcv

You must try a lot of them, I have tryed Ctrl-Q Ctrl-S in Unicode Checker 1.54
It says it's Hex 13 shown as a "space" in Location Field
Ctrl-Q Ctrl-J Hex 0A does a LineFeed in Location Field, arrow up to see back
Ctrl-Q Ctrl-H Hex 08 Backspace

http://www.earthlingsoft.net
In Glyph field type "a" or Ctrl-Q-Ctrl-S (without the - separators) then Enter
to show its value

Comment 3

16 years ago
Hm, I guess I see this using Chimera/2002112604. If you already have some text
in the location field, entering a control+q/control+s sequence does erase that
text. I don't know if it's actually putting anything else in its' place, though.

The same sequence has no effect using FizzillaMach/2002112607.

Comment 4

16 years ago
Some of these are emacs key bindings (Ctrl-h to delete, Ctrl-a to go to the
start of the text), which Cocoa text fields support by default.

I think the real bug here is that the URL bar lets you type characters that are
illegal in URLs. But if we use the url bar for searching, then we'd want to
allow them.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

15 years ago
Target Milestone: --- → Camino1.2

Comment 5

14 years ago
The URL bar can be used for searching, so you should be able to type whatever
you want. That said, I can't reproduce this bug in current nightly.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.