Closed Bug 1827962 Opened 1 year ago Closed 1 year ago

Create test for bug 1826659 - dropdown of split menu buttons in message header can now be opened with Enter or Space key

Categories

(Thunderbird :: Disability Access, task, P3)

Tracking

(thunderbird_esr115? fixed, thunderbird115 fixed)

RESOLVED FIXED
116 Branch
Tracking Status
thunderbird_esr115 ? fixed
thunderbird115 --- fixed

People

(Reporter: solange, Assigned: solange)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(1 file)

Update the test from Bug 1825904 to include testing for enter key and space bar

Whiteboard: [snnot]
Summary: Create test for bug 1826659 Message Header can now be activated with enter and space key → Create test for bug 1826659 - dropdown of split menu buttons in message header can now be opened with Enter or Space key
Whiteboard: [snnot] → [snnot3p]
Priority: -- → P3
Whiteboard: [snnot3p] → [Supernova3p]
Blocks: sn-msgreader
No longer blocks: sn-folderpane
Attachment #9338388 - Attachment description: WIP: Bug 1827962 - Create test for dropdown of split menu buttons in message header can now be opened with Enter or Space key. → Bug 1827962 - Create test for dropdown of split menu buttons in message header can now be opened with Enter or Space key. r=elizabeth,#thunderbird-front-end-reviewers
Status: NEW → ASSIGNED
Target Milestone: --- → 116 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/5c95eaffa20d
Create test for dropdown of split menu buttons in message header can now be opened with Enter or Space key. r=elizabeth

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9338388 [details]
Bug 1827962 - Create test for dropdown of split menu buttons in message header can now be opened with Enter or Space key. r=elizabeth,#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: If there are any error with the msgHdr we wouldn't be able to catch them and file them accurately.
Testing completed (on c-c, etc.): Automated testing added
Risk to taking this patch (and alternatives if risky): low as it is just a test for a feature that already exists

Attachment #9338388 - Flags: approval-comm-beta?

Comment on attachment 9338388 [details]
Bug 1827962 - Create test for dropdown of split menu buttons in message header can now be opened with Enter or Space key. r=elizabeth,#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta

Attachment #9338388 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: