Closed Bug 1828339 Opened 1 year ago Closed 1 year ago

double click on icon in message list opens the email in a tab

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect

Tracking

(thunderbird_esr102 unaffected, thunderbird114 affected)

RESOLVED FIXED
114 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird114 --- affected

People

(Reporter: soeren.hentzschel, Assigned: aleca)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

STR:

Double click one of the icons in the message rows, for example the star icon.*

Actual:

The email opens in a tab.

Expected:

The email should not open in a tab.

*) Before you ask why I did this: I don't think that there is a real use case to double click on the star icon. I observed this behaviour because I clicked the star icon on the wrong message and wanted to immediately revert it. And I was so fast with my two clicks that it was interpreted as a double click.

Whiteboard: [Supernova]

This also applies to the thread arrow and is particularly painful when you are opening and closing threads.

Whiteboard: [Supernova] → [Supernova3p]
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Target Milestone: --- → 114 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/4ffc133d266a
Prevent row activation if double click happens on a child button. r=leftmostcat

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: