Closed Bug 1828566 Opened 11 months ago Closed 3 months ago

New wpt failures in /html/semantics/popovers/popover-shadow-dom.html

Categories

(Core :: DOM: Core & HTML, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1867737

People

(Reporter: mozilla.org, Unassigned)

References

(Depends on 1 open bug)

Details

(Whiteboard: [wpt])

Syncing wpt PR 39560 found new untriaged test failures in CI

Tests Affected

New Tests That Don't Pass

CI Results

Gecko CI (Treeherder)
GitHub PR Head

Notes

These updates will be on mozilla-central once bug 1828216 lands.

Note: this bug is for tracking fixing the issues and is not
owned by the wpt sync bot.

This bug is linked to the relevant tests by an annotation in
https://github.com/web-platform-tests/wpt-metadata. These annotations
can be edited using the wpt interop dashboard
https://jgraham.github.io/wptdash/

If this bug is split into multiple bugs, please also update the
annotations, otherwise we are unable to track which wpt issues are
already triaged. Resolving as duplicate or closing this issue should
be cause the bot to automatically update or remove the annotation.

Severity: -- → S3
Depends on: popover
Assignee: nobody → mbrodesser
Status: NEW → ASSIGNED

Depends on bug 1824374 because one subtest uses popovertarget.

The other currently failing subtests use and hence depend on the anchor attribute which belongs to the CSS Anchor Positioning (https://drafts4.csswg.org/css-anchor-position-1/), which isn't implemented in Gecko yet.

Depends on: 1824374
Assignee: mbrodesser → nobody
Status: ASSIGNED → NEW

The sub-test failure is related to Anchor positioning, which is not yet supported in Gecko.

Duplicate of this bug: 1800283
Status: NEW → RESOLVED
Closed: 3 months ago
Duplicate of bug: 1867737
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.