Multiple logins/passwords for the same page, new from 1.2

VERIFIED DUPLICATE of bug 182490

Status

--
major
VERIFIED DUPLICATE of bug 182490
16 years ago
14 years ago

People

(Reporter: kalin, Assigned: morse)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021126

Since I upgraded to mozilla 1.2 I found this.
I have several pages with multiple logins (think of a web mail with many
accountts). The first time when I started 1.2 everything was normal, i.e. I was
prompted to choose a login.
Next time, however, I was NOT prompted and instead one of the logins was filled in.

Restarting browser didn't help. Copying the old *.s file solved the problem for
one (the first) time ONLY. Running a diff on the two files shows some differences.

Reproducible: Always

Steps to Reproduce:




Will debug some more now, about the theme and whether it was the first login in
the stored list or the last one used.
(Reporter)

Comment 1

16 years ago
It does not seem to depend on the theme, tried with Classic and Pinball.

The login used is the one last used (when first started mozilla with the old *.s
file).

Some more detailed diff output from the two *.s files:

The old *.s file:
domain00.com
username
~string00
*password
~string01
.


The new *.s file:
http://domain00.com
username
~string00
*password
~string01
.

As can be seen, a "http://" prefix was added.

(Reporter)

Comment 2

16 years ago
OK, I think I got it now!

I just manually changed all the lines in my *.s file to start with http:// and
everything is working perfectly.

Did Password manager change for 1.2? the way it stores URLs?

Why not document it and make it change all the occurunces of multiple logins to
start with http:// ?

I can see a trouble with https:// though :-) nad all the other protocol:// URLs...

I didn't try, but I guess this will not reproduce with a clean profile and 1.2,
you understand why. and I guess it is present in all 1.2 builds, not only on linux.
(Assignee)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 182490 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.