Babylon Hebrew-English Dictionary won't display and translate Hebrew

VERIFIED INVALID

Status

()

Core
Layout: Text
P4
minor
VERIFIED INVALID
15 years ago
10 years ago

People

(Reporter: Raymond A. Chamberlin, Assigned: smontagu)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016

The mini-window of the Babylon dictionary program [See http://www.babylon.com/],
when set up to translate from Hebrew to English online or offline, cannot
display a Hebrew word in its window, and hence cannot translate it to English. 
The program apparently sees only one or two characters that enclode one Hebrew
character of the Hebrew word entered into the window (by either copying same
from, or clicking on same, in a Web page or document).

This use of Babylon works fine for me when using IE.

Ray

Reproducible: Always

Steps to Reproduce:
1. Download a trial version (full but time-limited) of Babylon.
2. Download its Hebrew-(to)-English glossary.
3. Try to translate a Hebrew word from a document or Web page using Moz.  Then
try the same with IE.

Actual Results:  
The Babylon mini-window, only in the case of Moz, displayed only 1 or 2 ASCII
characters and gave false translation results.

Expected Results:  
Somehow caused the Babylon window to display proper Hebrew characters, which
would then result in a proper translation of the Hebrew word into English.  (I
don't understand how the design of the particular browser used affects how the
Babylon window acts.)

In re "Severity", the only work-around for this that I know is to use IE
(horrors), but I don't know how many people use Babylon.
(Reporter)

Comment 1

15 years ago
Maybe you want this in the Hebrew=Arabic-problem category, but I don't think it
has anything to do with the direction of reading/writing.

Ray
(Assignee)

Comment 2

15 years ago
OK, I'll download the trial version of Babylon to check this out.
(Assignee)

Comment 3

15 years ago
What seems to be happening is that, e.g. when I click on the first word in a
line of Hebrew, Babylon is copying the last word of the line to its window. If I
first select the word I want in Mozilla and then make the mouse click which
activates Babylon, it seems to work OK.

I have no idea how Babylon does what it does, but I suspect it may be using some
API designed for accessibility tools.
Status: UNCONFIRMED → NEW
Component: Internationalization → BiDi Hebrew & Arabic
Ever confirmed: true

Comment 4

15 years ago
Just FYI, this problem was identified and fixed in the next bug fix release of 
Babylon (4.0.3) that will be released in a few weeks. It was not a mozilla 
problem.

Updated

15 years ago
Priority: -- → P4
Target Milestone: --- → Future

Comment 5

14 years ago
Resolving per comment #4.
Raymond, if you still see this bug with current versions of the involved
programs, please report!
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

14 years ago
OK, I downloaded the Babylon update from 4.x.x.x to 4.0.5 and am currently using
Moz 1.6.  Using URL:  http://www.haaretz.co.il/   , Babylon appears to be
working as well as it can, from Hebrew to English -- the same way in Moz as in
IE (My Netscape 4.8 is not set up for Hebrew font.).  In either browser, the
more traditional Hebrew font works correctly consistently, using the
CTRL-right-click method.  I get spurious responses -- mostly 'no result',
sometimes even a call-up of the Spanish glossary -- with either Moz or IE, when
I try Babylon on the more modernized Hebrew fonts on this page.  Babylon says I
can also translate by copying words from a Web page (or elsewhere) into its slot
and clicking on 'Go' or using the Enter key.  I guess that's normally only for
Western fonts, unless you have a way of putting other fonts into the clipboard,
because I can't make that work with Hebrew here.

I agree:  Resolved Invalid.

Ray

Comment 7

14 years ago
v per comment #6
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: amyy → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.