Closed Bug 1828830 Opened 10 months ago Closed 8 months ago

Ability to open context menu in the message list by keyboard is not reliable

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 114

Tracking

(thunderbird115 fixed, thunderbird116 fixed)

RESOLVED FIXED
116 Branch
Tracking Status
thunderbird115 --- fixed
thunderbird116 --- fixed

People

(Reporter: pvagner, Assigned: freaktechnik)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

Steps to reproduce:

This is with Thunderbird 114.0a1 (2023-04-18) (64-bit version) on linux

  • Open thunderbird and navigate to folder with a lot of messages. I can't find out how many but I've managed to reproduce it with about 100 items. I was unable to reproduce it with 20 messages in the list.
  • Use F6 or shift+F6 to focus the message list
  • Press the home key to select the first item in the list
  • Now press shift+end to select all the messages
  • When all the messages are selected press shift+F10 or the applications key to open the context menu

Actual results:

Nothing has happened, messages are selected but context menu is not showing.

Expected results:

I would expect the context menu to appear.
Notice that the context menu will open as expected when using ctrl+a to select all the items or when navigating to the last item by using the end key and then selecting with shift+home.

Keywords: access, regression
OS: Unspecified → All
Hardware: Unspecified → All
See Also: → 1819277
Whiteboard: [Supernova]
Whiteboard: [Supernova] → [Supernova3p]

I am not able to reproduce this on Mac beta or daily.
Christian, you reproduce?

Flags: needinfo?(chriechers)

TB on Linux.
I'm trying to follow the steps to get to the last point with all messages selected, but it doesn't work for me.
Also I don't understand the point of doing all this when a simple Ctrl-A will select all messages. In that case I also do get the context menu when pressing Shift-F10.

Flags: needinfo?(chriechers)

(In reply to Christian Riechers from comment #2)

TB on Linux.
I'm trying to follow the steps to get to the last point with all messages selected, but it doesn't work for me.
Also I don't understand the point of doing all this when a simple Ctrl-A will select all messages.

Just a different way to achieve the same thing

In that case I also do get the context menu when pressing Shift-F10.

Peter is it now working for you?

Flags: needinfo?(pvagner)

Hello,
I can still reproduce this with Thunderbird 114.0a1 (2023-05-04) (64-bit version) on linux.
My workflow is like this

  • Order messages by date
  • Press the end key to move to the bottom (the most recent message)
  • Use page up and up / down arrow keys to select the first message I wish to select from
  • Press shift+end to make the selection
  • Press shift+F10 to popup a menu.

And when selecting top to bottom context menu is not shown. When selecting bottom to top, context menu is shown.

So I have only used steps simulating select all as an example, I believe this should work the same way no matter of the navigation direction it's why I have filled it.
Fortunatelly there are workarounds.

Flags: needinfo?(pvagner)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(elizabeth)

Initial update 1: I just tested this on a Mac and am not able to open the menu with Shift + F10, though it previously worked. I will work on this with bug 1825393. I wonder if there was a regression at some point. That's why having the tests in is important.

Update 2: It worked on Windows previously. I just tested this on Windows 11 and it works fine. This may be a Linux and Mac-specific issue.

Update 3: I confirmed with Micah, who uses Linux, that Shift + F10 does not work on Linux. Nothing happens. He tested this with a single message and multiple messages selected.

Summary:

  • The context menu does not open by keyboard in Linux and macOS with Shift + F10. It does work with Windows 11.
  • Bug 1819277 did not adequately fix the context menu not working via keyboard (the solution only fixed Windows).
  • Tests will be implemented to catch this problem in the future in bug 1825393.
Assignee: nobody → elizabeth
Status: NEW → ASSIGNED
Flags: needinfo?(elizabeth)
Priority: -- → P2
Summary: Ability to open context menu in the message list not reliable → Ability to open context menu in the message list by keyboard does not work in macOS and Linux

I am testing with
115.0a1 (2023-05-31) (64-bit version)
and also with
115.0a1 (2023-06-05) (64-bit version)
I am on linux on X.org and I can open the context menu when pressing shift+F10 or the so called applications key located on the right hand side on the bottom of the keyboard usually to the left of the right ctrl key.
It's just the number of messages being selected and the navigation direction when selecting them matters for me the same way I have described it in my initial report and later explanatory comments.
Resolving the Bug 1819277 did have huge impact on how I am using thunderbird. So perhaps there are other situations where this fails on mac and linux.
Do you think I can improve my steps? Because I am afraid we may missunderstand each other. Or is there really a chance you might have so different results on mac and linux to what I am seeing?
Or is it possible the context menu is shown, it can be navigated and its actions can be executed with a screen reader running but it's not visible on the screen?
With orca on linux I immediatelly hear menu when pressing shift+F10 in the message list and I can use up and down arrow key to navigate.

See Also: → 1836846

(In reply to Peter Vágner from comment #6)

I am testing with
115.0a1 (2023-05-31) (64-bit version)
and also with
115.0a1 (2023-06-05) (64-bit version)
I am on linux on X.org and I can open the context menu when pressing shift+F10 or the so called applications key located on the right hand side on the bottom of the keyboard usually to the left of the right ctrl key.
It's just the number of messages being selected and the navigation direction when selecting them matters for me the same way I have described it in my initial report and later explanatory comments.
Resolving the Bug 1819277 did have huge impact on how I am using thunderbird. So perhaps there are other situations where this fails on mac and linux.
Do you think I can improve my steps? Because I am afraid we may missunderstand each other. Or is there really a chance you might have so different results on mac and linux to what I am seeing?
Or is it possible the context menu is shown, it can be navigated and its actions can be executed with a screen reader running but it's not visible on the screen?
With orca on linux I immediatelly hear menu when pressing shift+F10 in the message list and I can use up and down arrow key to navigate.

Thank you for this information. This is very helpful. Your instructions are clear in comment 0 and comment 4.

Thank you for surfacing this problem.

Yes, it sounds like the visual context menu is not showing in macOS and Linux. I have created a separate bug as bug 1836846 to address this.

Summary: Ability to open context menu in the message list by keyboard does not work in macOS and Linux → Ability to open context menu in the message list by keyboard is not reliable
No longer blocks: 1825393
See Also: → 1825393

We found the issue.
If the first selected message is outside the viewport the menu could be triggered outside of the visibile window screen.

Assignee: elizabeth → martin
Attachment #9340489 - Attachment description: Bug 1828830 - Show message row into view when showing context menu. r=#thunderbird-front-end-reviewers → Bug 1828830 - Scroll message row into view when showing context menu. r=#thunderbird-front-end-reviewers
Target Milestone: --- → 116 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/1534f361e6b7
Scroll message row into view when showing context menu. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED

Comment on attachment 9340489 [details]
Bug 1828830 - Scroll message row into view when showing context menu. r=#thunderbird-front-end-reviewers

[Approval Request Comment]
Regression caused by (bug #): about:3pane rebuild
User impact if declined: Triggering the context menu with keyboard navigation will silently fail if the row isn't already scrolled into view, plus we show the context menu on the wrong item.
Testing completed (on c-c, etc.): Manual testing only so far.
Risk to taking this patch (and alternatives if risky): Low risk, only changes code for showing the context menu on message rows.

Attachment #9340489 - Flags: approval-comm-beta?

Comment on attachment 9340489 [details]
Bug 1828830 - Scroll message row into view when showing context menu. r=#thunderbird-front-end-reviewers

[Triage Comment]
approved for beta

Attachment #9340489 - Flags: approval-comm-beta? → approval-comm-beta+
Blocks: 1841251
Regressions: 1867532
You need to log in before you can comment on or make changes to this bug.