If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla startup crash when compiling with xft support [@ GetNormalLineHeight ]

RESOLVED DUPLICATE of bug 180309

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 180309
15 years ago
13 years ago

People

(Reporter: Isam Bayazidi, Assigned: asa)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.1; Linux)
Build Identifier: CVS fresh checkout Saterday 30 Nov, 2002

I compiled a  daily snapshot version of Mozilla (1.3a) it with the following options: ./configure  --enable-crypto  --prefix=/opt/mozilla-xft  --enable-xft --enable-xinerama  --disable-tests make, and make install went perfect .. when I attempt to run mozilla I get a start up crash.  I hope that the included info is enough.. I am willing to give what ever debug info I can provide that is needed  

Reproducible: Always

Steps to Reproduce:
1. compile mozilla daily snapshot with xft support 2. run mozilla 3. get a crash 
Actual Results:  
I got a crash 

Expected Results:  
startup 

gdb result ( last few lines before exiting with a crash) : ----------------------------------------------------------------------- ###!!! ASSERTION: font metrics should not be null - bug 136248: 'NS_SUCCEEDED(rv)', file nsDeviceContext.cpp, line 707 Break: at file nsDeviceContext.cpp, line 707 ###!!! ASSERTION: no font metrics: 'nsnull != aFontMetrics', file nsHTMLReflowState.cpp, line 2283 Break: at file nsHTMLReflowState.cpp, line 2283  Program received signal SIGSEGV, Segmentation fault. [Switching to Thread 1024 (LWP 1771)] 0x418171fd in GetNormalLineHeight (aFontMetrics=0x81751c0)     at nsHTMLReflowState.cpp:2307 2307      aFontMetrics->GetNormalLineHeight(normalLineHeight); -------------------------------------------------------------  the backtrace result would be:  ------------------------------------------------------------- #0  0x418171fd in GetNormalLineHeight (aFontMetrics=0x81751c0)     at nsHTMLReflowState.cpp:2307 #1  0x419ea527 in _Q214nsICanvasFrame27GetIID__14nsICanvasFrame ()    from /opt/mozilla-xft/lib/mozilla-1.3a/components/libgklayout.so -----------------------------------------------------------------

Comment 1

15 years ago
dupe of bug 180309 ?
Keywords: crash
Summary: Mozilla startup crash when compiling with xft support → Mozilla startup crash when compiling with xft support [@ GetNormalLineHeight ]

Comment 2

15 years ago
i'm sorry i wasn't able to help over the weekend, i actually love null
fontmetrics bugs :)

*** This bug has been marked as a duplicate of 180309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Crash Signature: [@ GetNormalLineHeight ]
You need to log in before you can comment on or make changes to this bug.