sun.com - After <b> all text is underlined on mouseover

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
VERIFIED FIXED
16 years ago
3 years ago

People

(Reporter: Manoj, Assigned: Susie Wyshak)

Tracking

Details

(Whiteboard: [syntax-html], URL)

(Reporter)

Description

16 years ago
Browser: Phoenix 0.4, Build Id 20021118
OS: Windows .Net Server 

The url on Sun's website uses anchors like so:

<a name="" /><h4>What's new and cool in Solaris 9 software</h4>
<span class=grey><ul>

All the text that follows the anchor tag gets underlined if the css on the page
indicates that links should be underlined on hover. This page does not exhibit
the same behaviour on IE. Only the links get underlined.

I looked up the HTML Tag reference at DevEdge and this is what the reference has
to say:

<A 
  NAME="anchorName"
>
...
</A>

Example

<A NAME=section2>
<H2>A Cold Autumn Day</H2></A>

Nowhere in the spec does it say that <a name="blah" /> should be supported, so I
am thinking this is either an extension of the spec or should be taken up by
Evangelism to correct the matter.

Comment 1

16 years ago
seeing this on Linux too build 2002120104.

*** This bug has been marked as a duplicate of 160822 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
OS: Windows XP → All
Resolution: --- → DUPLICATE

Comment 2

16 years ago
reopening, the dupe is fixed, not this one.
Sent feedback e-mail.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Funny behaviour with the <a name="blah" /> tag → sun.com - After <b> all text is underlined on mouseover
Whiteboard: [syntax-html]
(Reporter)

Comment 3

16 years ago
The following link exhibits a similar problem:

http://news.ft.com/servlet/ContentServer?pagename=FT.com/StoryFT/FullStory&c=StoryFT&cid=1039523785796

Viewing the source of this link indicates extensive usage of  /> to end tags
like the form tag. The entire article is underlined. Is this tech evang too?

Comment 4

16 years ago
got answer from Sun: "Thank you for your message. Unfortunately the anchor tags
are automatically inserted by our content management system and cannot easily be
removed. We are sorry for the inconvenience."
Assignee: jst → susiew
Status: UNCONFIRMED → NEW
Component: DOM HTML → US General
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: stummala → zach
Version: Trunk → unspecified
(Assignee)

Comment 5

16 years ago
ccing other evangs.

Comment 6

16 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 7

16 years ago
v. thanks Olivier!
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.