On CGI pages that are that have the same URL a view source returns the source of the default URL but not of the page shown (which has been altered by the CGI)

RESOLVED DUPLICATE of bug 153884

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 153884
16 years ago
16 years ago

People

(Reporter: Kevin Finn, Assigned: saari (gone))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021201 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021201 Chimera/0.6+

It seems that a view source issues another call to the URL to download the
source HTML but this isn't always the desired result.  I have a simple CGI
script that takes input and returns an altered page but maintains the same URL.
 As a result a view source of the altered page calls the URL for the source code
but does not reissue the input variables and as a result the source code
returned is that of unmanipulated page.  This is incorrect as the HTML I want is
that of the manipulated page.  The lastest Mozilla builds do not have this
problem as it returns the HTML on hand of the manipulated page although Chimera
does not function in this manner.   

Reproducible: Always

Steps to Reproduce:
1. http://kevfinn.com/shop
2. click on "I Want One" to add a T-shirt to the shopping cart
3. view source of the subsequent shopping cart page


Actual Results:  
This source is that of the initial shop page, not of the cart page. 

Expected Results:  
On a view source Chimera should return the HTML of the subsequent CGI page that
happens to share the same URL (Mozilla handles this correctly however).

Comment 1

16 years ago
Duplicate, 153884
(I myself am guilty of the same, 182526)

Mark

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 153884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.