Closed Bug 1829095 Opened 10 months ago Closed 9 months ago

Too many tab stops on column headers of message list in classic tabular view

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Thunderbird 114

Tracking

(thunderbird_esr102 unaffected, thunderbird114 affected)

RESOLVED DUPLICATE of bug 1819281
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird114 --- affected

People

(Reporter: thomas8, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access, ux-efficiency, Whiteboard: [Supernova3p])

+++ This bug was initially created as a clone of Bug #1783172 +++

The everyday scenario of keyboard-navigating with Tab to the message list now takes 10 or more tab stops as we're passing through each and every column header - that's way too many, and needs way too much focus (pun intended)!

Accessibility is good. Too many tab stops for basic scenarios isn't.
Rule of thumb: Multiple adjacent elements of the same type should only have a single tab stop, reach the rest with arrow navigation. Which is good ARIA practice, too!

STR

  1. Select/focus a folder in folder list with View > Layout > Classic View (3-pane with tabular message list).
  2. Press Tab as often as required to focus the first message in the message list

Actual result

  • 10 or more Tab keypresses needed: each column header is a tab stop
  • With quick filter bar open, 17 tab stops or more (bug 1827251)
  • everyday scenario of navigation to the message list is extremely inconvenient, plus the number of tabs may change depending on number of columns, so it needs more attention and it's hard to develop muscle memory

Expected

  • Single tab stop at the column header which the message list is currently sorted by (e.g. Date)
  • Column header tab stop should come after the message list, not before (to reduce the number of keystrokes from folder list to message list)
  • Then any other column headers can be focused using arrow-right/left
Summary: Too many tab stops on column headers of message list → Too many tab stops on column headers of message list in classic tabular view
Keywords: access
Component: Address Book → Folder and Message Lists
Version: Thunderbird 102 → Thunderbird 114
Blocks: 1829099
No longer blocks: 1829099
Whiteboard: [supernova] → [Supernova3p]

Pretty big usability issue for accessibility and regular keyboard users.

Actual result

  • 10 or more Tab keypresses needed: each column header is a tab stop
  • With quick filter bar open, 17 tab stops or more (bug 1827251)
  • everyday scenario of navigation to the message list is extremely inconvenient, plus the number of tabs may change depending on number of columns, so it needs more attention and it's hard to develop muscle memory
Summary: Too many tab stops on column headers of message list in classic tabular view → Too many tab stops on column headers of message list in classic tabular view - hard to reach message list from folder list

There's no need to reiterate what was reported in the first description. Also, please don't extend the bug summary with extra information that don't add much value.
We know this is not ideal and we will fix it when we can.
F6 allows to quickly jump to the message list.

Summary: Too many tab stops on column headers of message list in classic tabular view - hard to reach message list from folder list → Too many tab stops on column headers of message list in classic tabular view
Status: NEW → RESOLVED
Closed: 9 months ago
Duplicate of bug: 1819281
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.