Closed Bug 182912 Opened 19 years ago Closed 19 years ago

sender and recipient choices needed on dropdown menu of header info

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

x86
Windows 98
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 36492

People

(Reporter: allltaken, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021126

Using build Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021126:

On the mail window, there's a bar listing mail header info such as subject,
sender  or recipient, read/unread, date, etc. On the right end of that bar,
there's a dropdown menu listing available pieces of info to display. On a
closed-out "sent" mailbox that I manually renamed Sent026, the recipient info is
NOT one of the pieces of header info that can be selected, only sender. To make
that dropdown menu useful for displaying backup mail files, it would be VERY
useful to add "Recipient" to the header info selectable by the menu and
displayable in the mail and newsgroup window.

Reproducible: Always

Steps to Reproduce:
1.Click on a backup "sent" mailbox, or copy Sent as (for example) Sent001 and
click on it to find messages you sent to someone.
2. Note that recipients are not shown, only the sender (you). Click on the
button to show the dropdown menu of displayable header items and note that
Recipient is not one of the choices.
3. Open each individual message to search for messages to the recipients of
interest. Note that you can't tell Mozilla to search because it only searches
"sender" info, not "recipient" info, when anything but Inbox is displayed.

Actual Results:  
You tediously open perhaps several hundred messages to find the one or several
that you want, instead of displaying "recipient", sorting by recipient and
finding the wanted messages quickly.


Expected Results:  
Make both Sender and Recipient choices on the dropdown menu for ANY mailbox
including collected newsgroup messages, and show either Sender or Recipient or
both as the user specifies.


The failure to show recipient info at all was introduced in some earlier
version, I think a Netscape 4.x or 6.x version, and was continued in Mozilla
until Mozilla 1.2b, I think. But there is more improving to do on this to
improve usability. Should the absence of ability to search on the Recipient
field in any mailbox except Inbox be written up as a separate "enhancement" bug?
You could call this an enhancement, except that I'm pretty sure these
inconveniences didn't exist in early Netscape 4.x or earlier versions, and other
users commenting on this noted that these limitations seriously diminish
usability for serious email users including corporate users.

*** This bug has been marked as a duplicate of 36492 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
QA Contact: olgam → laurel
marking verified as a duplicate
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.