bad character set detection for '<emdash>t' (Windows 1252)

RESOLVED DUPLICATE of bug 168526

Status

MailNews Core
Internationalization
RESOLVED DUPLICATE of bug 168526
15 years ago
9 years ago

People

(Reporter: timeless, Assigned: smontagu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
I got bugmail for bug 181711 comment 3, mozmail (imap connection) - cvs build
from about two weeks ago rendered "output葉hat", displaying the source/message
as Western (ISO-8859-1) triggers results in "output—that".

Oddly the character coding is listed as Western (ISO-8859-1) even while
universal autodetect is triggering 葉.
(Reporter)

Comment 1

15 years ago
Created attachment 107923 [details]
the email

When loaded from a file in navigator, i get Western (Windows-1252):
output葉hat
(Assignee)

Comment 2

15 years ago
Can anyone reproduce this in an up-to-date build? It might be a similar issue to
bug 180988
(Assignee)

Comment 3

15 years ago
In fact it's much more similar to bug 168526

Comment 4

13 years ago
Duping to the browser autodetect bug.

Bug 253849 opened for the failure of the Mail/News View|Encoding menu to update, 
which is a common symptom to some otherwise distinct Mail/News charset bugs.

*** This bug has been marked as a duplicate of 168526 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Summary: bad character set detection for '—t' → bad character set detection for '<emdash>t' (Windows 1252)
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.