cybercorp.com - traceroute java page never loads

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Details

(Whiteboard: [havefix][havecontact], URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

test2.cybercorp.com is a tracroute java page from CyberCorp that only seems to
run in MSIE. It doesn't run in Opera (6 or 7), and doesn't run on mozilla 1.1
either. I get the following in the Java Console:
load: class VisualRouteApplet.class not found.

java.lang.ClassNotFoundException: VisualRouteApplet.class

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

Caused by: java.net.ConnectException: Connection timed out: connect

	at java.net.PlainSocketImpl.socketConnect(Native Method)

	at java.net.PlainSocketImpl.doConnect(Unknown Source)

	at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

	at java.net.PlainSocketImpl.connect(Unknown Source)

	at java.net.Socket.connect(Unknown Source)

	at sun.net.NetworkClient.doConnect(Unknown Source)

	at sun.plugin.net.protocol.http.HttpClient.doConnect(Unknown Source)

	at sun.net.www.http.HttpClient.openServer(Unknown Source)

	at sun.net.www.http.HttpClient.openServer(Unknown Source)

	at sun.net.www.http.HttpClient.<init>(Unknown Source)

	at sun.net.www.http.HttpClient.<init>(Unknown Source)

	at sun.plugin.net.protocol.http.HttpClient.<init>(Unknown Source)

	at sun.plugin.net.protocol.http.HttpClient.New(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.privBlock(Unknown Source)

	at
sun.plugin.net.protocol.http.HttpURLConnection$PrivilegedBlockAction.run(Unknown
Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.plugin.net.protocol.http.HttpURLConnection.connect(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

	at java.net.HttpURLConnection.getResponseCode(Unknown Source)

	at sun.applet.AppletClassLoader.getBytes(Unknown Source)

	at sun.applet.AppletClassLoader.access$100(Unknown Source)

	at sun.applet.AppletClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	... 11 more



Reproducible: Always

Steps to Reproduce:
1. go to http://test.cybercorp.com
2.
3.

Actual Results:  
See details

Expected Results:  
For expected results, try MSIE (which I can't stand using).

Schwab tech support (Schwab owns CyberCorp) told me that the java app only works
with MSIE. Of course, they don't have a clue why. Maybe the developers are using
some MS Java that is not "standard"? Beats me, but it would not be very far-fetched.
-> oji
Assignee: asa → joshua.xia
Component: Browser-General → OJI
QA Contact: asa → petersen

Comment 2

16 years ago
Source code:

[...]
<applet codebase="http://test2.CyberTrader.com:80/"
code="VisualRouteApplet.class" width="750" height="900"><param name="codeBase"
value="http://test2.CyberTrader.com:8001/"><param name="code"
value="VisualRouteApplet.class"><param name="width" value="750"><param
name="height" value="900">Java support required!</applet>
[...]

IE will load applet from port 80, Netscape-like browser will load on port 8001
which doesn't work. Typo ?
Will attach testcase that works fine if using port 80 for Netscape/Mozilla.

Easy fix, propose to move to Tech Evangelism.

Comment 3

16 years ago
Created attachment 107956 [details]
Fixed page (works with Mozilla + JRE 1.4.1_01 and also NS4.8 + Java 1.1.5)

Comment 4

16 years ago
Reporter, can you contact them again and ask them to fix the Netscape plug-in
code to point to port 80 instead of 8001 ?
Status: UNCONFIRMED → NEW
Component: OJI → US General
Ever confirmed: true
OS: Windows XP → All
Product: Browser → Tech Evangelism
Hardware: PC → All
Whiteboard: [has fix][has contact]
Version: Trunk → unspecified
(Reporter)

Comment 5

16 years ago
Ok, contacted them, but I can't file a bug with CyberCorp. Filed it with the
Schwab Tech Support. Hopefully, they take care of it. Did get a very dumb
comment, though, telling me that it was only supposed to work with MS IE. Don't
think they "got it".

Comment 6

16 years ago
well, have them test attachment 107956 [details], it works fine with any browser. It'll
visually prove it works ok.

Updated

16 years ago
Summary: cybercorp traceroute java page never loads → cybercorp.com - traceroute java page never loads

Comment 7

16 years ago
so this is website's bug, should we close it?
Thanks!

Comment 8

16 years ago
Joshua, we should only close a Tech Evangelism bug when the website really fixed
the issue.

Comment 9

16 years ago
if this is not OJI/JPI 's bug, and confirm to be web site 's bug, should we mark
it to be  Resolve->invalid ?

Comment 10

16 years ago
not an OJI's bug, read comment 2.
This is "Tech Evangelism" Product, "US General" Component, not "OJI".
I don't have bandwidth right now, the QA and Assigned-to contacts should be changed.
Whiteboard: [has fix][has contact] → [havefix][havecontact]

Comment 11

16 years ago
reassigning.
Assignee: joshua.xia → susiew
QA Contact: petersen → zach

Comment 12

15 years ago
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us

Comment 13

14 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.