Editing keys fail to function after deleting inline Japanese/Chinese input

RESOLVED DUPLICATE of bug 179574

Status

Camino Graveyard
HTML Form Controls
--
major
RESOLVED DUPLICATE of bug 179574
15 years ago
15 years ago

People

(Reporter: stephen@ju-ju.com, Assigned: Brian Ryner (not reading))

Tracking

({intl})

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021202 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021202 Chimera/0.6+

After deleting yet-committed inline Japanese/Chinese input, editing keys like
left/right arrows and backspace stop functioning.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL above and place insertion point it the query field.
2. With U.S. keyboard, type some text in the field.
3. Switch to Kotoeri.
4. Type the following keys:
NIHONN<BACKSPACE><BACKSPACE><BACKSPACE>
This will type some inline Japanese text without committing them and then delete
them.
5. Type <BACKSPACE> key to delete any of the English text or <LEFT ARROW> key to
move within it.

Actual Results:  
<BACKSPACE> and <LEFT ARROW> keys have no effect at all. Insertion point does
not move and no character is deleted.

Expected Results:  
Delete character with <BACKSPACE> key and move insertion point with <LEFT ARROW>
key.

This happens with Chinese using TCIM, too.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 179574 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: intl
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.