Closed Bug 18303 Opened 20 years ago Closed 20 years ago

Program crash

Categories

(MailNews Core :: Composition, defect, P3, major)

x86
Windows 98

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: mystiq, Assigned: bugzilla)

Details

Im running Wingate 3.0.5 on my NT box, and when i hit send on Gecko Composer,
it has a heart attack and proceeds to crash rather nastily: (you can probably
guess that gecko refuses to download on anything but the gateway machine, but
that's another bug report...)

APPRUNNER caused an invalid page fault in
module MSGBSUTL.DLL at 023f:60929139.
Registers:
EAX=00000000 CS=023f EIP=60929139 EFLGS=00010246
EBX=60935090 SS=0247 ESP=0063e9fc EBP=0063ea18
ECX=60255504 DS=0247 ESI=019ea040 FS=0fe7
EDX=0063e9f8 ES=0247 EDI=00000000 GS=0000
Bytes at CS:EIP:
8b 08 ff 76 20 ff 76 1c 50 ff 51 28 8d 4d 0c c7
Stack dump:
019ea3d4 019ea040 0063ea54 019ea040 00000000 00000000 019ea3d4 0063ea64
6024ecad 019ea3d4 019ea3d4 019ea3d4 00000000 00000000 60ae38f0 019ea290
Pls provide add'l info:
1) build used
2) did you create a new mail profile?
3) what are your exact steps?

Pls review http://www.mozilla.org/quality/bug-writing-guidelines.html - thanks.
Build 19991006618 M10, i obviously made a new mail profile.

I clicked on New Msg in composer, typed in a recipient, typed in the subject,
body, clicked send, and it crashes. The last line of apprunner reads: "There are
1 smtp servers"

If you're into assembly, MSVC++ spit this out in file msgbsutil.dll:

First-chance exception in apprunner.exe (MSGBSUTL.DLL): 0xC0000005: Access
Violation.

60929135   push        esi
60929136   push        dword ptr [ebp+0Ch]
-> 60929139   mov         ecx,dword ptr [eax] <- crash
6092913B   push        dword ptr [esi+20h]
6092913E   push        dword ptr [esi+1Ch]
Status: NEW → ASSIGNED
Target Milestone: M12
Thanks for the info, I will investigate...
Cannot reproduce this crash and I don't have any clue about it!

mystiq, have you tried the new M11 build?
if yes, are you still crashing?
if yes, could you send me (mailto://ducarroz@netscape.com) your prefs.js file (But before, please remove or modify
any passwords this file contains).
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
As I cannot get more info from the reporter and as I cannot reproduce it, I am marking this bug as works for me!
Status: RESOLVED → VERIFIED
verified as worksforme.
mystiq@optonline.net - pls reopen if you still have the problem and let us know
the answers to ducarroz's questions. Thanks.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.