[MARGIN-C]A form with inline style and embedded table can move on submit.

RESOLVED DUPLICATE of bug 172816

Status

()

Core
Layout
--
minor
RESOLVED DUPLICATE of bug 172816
15 years ago
15 years ago

People

(Reporter: George Chrisbacher, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2) Gecko/20021126

May be related to bug 111438.
A form with style="display:inline" and an embedded table moves (the whole form
moves) when the submit button is clicked. Code to reproduce is attached in the
"Additional Information" field.
This issue is present in both 1.1.0 and 1.2.0, but NOT in 1.0.1

Reproducible: Always

Steps to Reproduce:
1. Load code from "Additional Information" field
2. Click "Login" button.
3. See form move

Actual Results:  
The form moves up a line or so.

Expected Results:  
form should stay still.

<html>
      <body>
      <table>
         <tr>
            <td>
               <p>&nbsp;</p>
               
               <form style="display: inline" onSubmit="return LoginFormValidate()">

               <table border="0">
                  <tr><td>UserID</td><td><input name="ID" type="text" value=""
size="16" maxlength="32" tabindex="1"></td></tr>
                  <tr><td>Password</td><td><input name="PW" type="password"
value="" size="16" maxlength="32" tabindex="2"></td></tr>
                  <tr><td colspan="2" align="center"><input name="Login"
type="submit" value="Login" tabindex="3"></td></tr>
               </table>

               </form>

               <script type="text/javascript">
      
               function LoginFormValidate()
               {
                  return false;
               }
               </script>
            </td>
         </tr>
      
      </table>

      </body>
      </html>
looks like an issue with margin-collapsing to me...
This works for me in my own build?  Perhaps it was fixed by my changes for bug
44242 which landed last week.  Could you try a newer build?
Summary: A form with inline style and embedded table can move on submit. → [MARGIN-C]A form with inline style and embedded table can move on submit.
(Reporter)

Comment 4

15 years ago
Appears to be fixed in nightly build 1.3.2002120304.

*** This bug has been marked as a duplicate of 172816 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.