crash when publishing calendar after selecting all events (ctrl+a)

RESOLVED FIXED

Status

Calendar
General
--
critical
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: Alex Ezell, Assigned: Mike Potter)

Tracking

({crash})

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021202
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021202

To publish my calendar (which has never worked), I was trying various things. I
was publishing to a WebDAV server that is setup correctly as I can publish
calendars to it from iCal on a Mac that I have here in my office.

One of the things that I tried was selecting all the events on a given calendar,
thinking that might publish them all rather than just a few events (a behavior
that occurred several times). To do this, I simply hit "Ctrl-A" to select all
the events.

Then I choose to "Publish Events" from the menu and when clicking "OK", Mozilla
did I hard crash.

Reproducible: Always

Steps to Reproduce:
1. Add some events to a calendar.
2. Select all (CTRL-A) the events.
3. Choose "Tools"
4. Choose "Publish Events"
5. Fill in the info for a working WebDAV server.
6. Click "OK"

Actual Results:  
A hard crash giving some esoteric error message that I can't copy right now, or
Mozilla will crash and I will have to type all this in again. :)

Expected Results:  
Published the events to the server and given me some indication that the publish
was successful.

I will add the module info about the crash after submitting, so I don't lose all
this typing.
(Reporter)

Comment 1

15 years ago
Created attachment 107947 [details]
JPG screenshot of the crash error.

I couldn't copy out the text, so I just made a screenshot of the error that
Mozilla gave when crashing.

Comment 2

15 years ago
I have confirmed this issue with Mozilla Calendar 2002112809-cal
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021205.

Since Talkback didn't start, here are details caught by Bugtoaster for crash
signature 140854:

Executable  File Name  Version  Company  Bugtoaster File #  Base Address  End
Address  Beta?
Process mozilla.exe 1.3a  Mozilla, Netscape  51406  4194304 4306880 False
DLL msvcrt.dll  7.0.2600.1106 (xpsp1.020828-1920)  Microsoft Corporation  45701
 2009137152  2009460224  False 
 
Addresses
Exception Address 0x0 
Exception Address
Normalized 0x0 
EIP 0x 
EIP Normalized 0x336D0 
EIP Section 0x0 
EIP Section Offset 0x326D0 
Stack
SS 0x23
ESP 0x12FFF8
Stack Top 0x130000
Stack Bottom 0x11B000
Registers
EAX 0x0
EBX 0x3284C12
ECX 0x179836C
EDX 0x0
EBP 0x0
ESP 0x12FFF8
EDI 0x32D4834
ESI 0x12CBDC
Segment Registers
SS 0x23
CS 0x1B
FS 0x38
GS 0x0
DS 0x23
ES 0x23
EFlags 0x246
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
OS: Windows 2000 → All

Comment 3

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

I also got this error when selecting all and then "Publish events..."

But when I tried "Select All" and then "Export events...", Mozilla crashed too.
So I think the problem is somewhere in the "Select All" and not in the Publish
or Export actions.
(Assignee)

Comment 4

15 years ago
This works fine for me, is anyone still seeing this problem?
Status: NEW → ASSIGNED
(Reporter)

Comment 5

15 years ago
I am still seeing the problem as described before. I am currently using this 
build: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030102




Still using Ctrl-A to select all events and then "Publish Events..." then Moz 
crashes.
(Assignee)

Comment 6

15 years ago
This works fine for me now. I don't see a crash with the latest XPI.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 7

15 years ago
This appears in an alert if I select none, publish, fill in nothing, click OK.

[Exception... "Component returned failure code: 0x804b0012
[nsIIOService.newChannelFromURI]" nsresult: "0x804b0012(<unknown>)"
location: "JS frame :: chrome://calendar/content/publish.js ::
create_channel_from_url :: line 206" data: no]
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 8

15 years ago
OK, publishing problems are mostly fixed now, but I saw this bug as I was doing
some testing.
If someone can reproduce this bug, please attach your .ics file.
I had a single event I was trying to publish, and it would crash when trying to
clone it.  I deleted the event, and added a new event, and I can publish it fine.
So, I need an .ics file that causes the crash, so I can see what is in that
event that causes it.
(Assignee)

Comment 9

15 years ago
OK, I'm going to make this one as fixed now.
The crash no longer happens, so this bug is done.
I've added in some code to disable Publish Selected Events if no events are
selected. I've also added some code to try and force the user to type something
in the URL field so they don't get that JS error.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.