Closed Bug 18308 Opened 20 years ago Closed 20 years ago

parser sees white space between adjacent tags: </head><body>

Categories

(Core :: HTML: Parser, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: jcarpenter0524, Assigned: harishd)

Details

Attachments

(3 files)

Overview Description:
The parser should see white space [object Text] when there is a return between
tags, but currently it sees an [object Text] even when the tags are side by
side.

Steps to Reproduce:
- see attached testcases

Actual Results:
from the attached testcase:
[object HTMLHeadElement]
[object Text]
[object HTMLBodyElement]

Expected Results:
from the attached testcase:
[object HTMLHeadElement]
[object HTMLBodyElement]
null

Build Date & Platform Bug Found:
1999110809 WinNT

Additional Builds and Platforms Tested On:
1999110809 Win98
1999110808 Mac
1999110808 Linux
Aargh! That was supposed to go on the first bug in my buglist.  Sorry.  Ignore
that screenshot.
Assignee: harishd → rickg
Blocks: 18951
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
I can't reproduce this problem.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
still happening on commercial build.  Are you using a debug build?  maybe it
doesn't happen there?
Assignee: rickg → harishd
Status: REOPENED → NEW
Assigning the bug to myself.
Oops...created attachement for the wrong bug!!! Ignore the attachment please.
Fixed by updating CNavDTD.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
No longer blocks: 18951
updated qa contact.
QA Contact: janc → bsharma
Verified on:
Build: 2001-04-25-09-Trunk
Platform: WinNT

The attached test case loads fine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.