Multi day events won't allow end times to be before start times

RESOLVED FIXED

Status

Calendar
General
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: Neil Williams, Assigned: Mike Potter)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021113

I just tried to add my work's Xmas holidays.  The event went from 13:00 on the
24/12/02 to 8:00 on 2/1/03 (British format dates!) On completeing the end time I
got the message " Your end time is before your start time" and then , obviously,
it would not let me complete the event.  thinking that this may be a problem
because of the change of year I tried it on the 10/12/02 to 13/12/02 start time
4:00 end time 2:00 same result

Reproducible: Always

Steps to Reproduce:
1. Create event starting on any day at a start time
2. Set end time time earlier than start time on a following day

Actual Results:  
Get the message " Your end time is before your start time"

Expected Results:  
Event should have set correctly with an end time 'earlier' than the start time
on the following day

Comment 1

15 years ago
Created attachment 108355 [details] [diff] [review]
Patch to fix the bug.

This patch fixes the bug of not allowing an end time before the start time even
when the end day is after the start day.
This patch also stops the end day begin before the start day.
Also the recurrence testing has been made stricter.

Comment 2

15 years ago
Created attachment 109951 [details] [diff] [review]
This time the patch works...

Should test my code more.
Attachment #108355 - Attachment is obsolete: true

Comment 3

15 years ago
*** Bug 184136 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
Matt, I am assigning this to you since you have been working on it.  Accept it
if that is okay with you.  If you don't have CVS access, reassign to Mike when
you are confident with your patch.
Assignee: mikep → buckett
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
Created attachment 110270 [details] [diff] [review]
An improved patch

Previously when an error message was displayed the window did not resize and so
the Ok/Cancel buttons could drop out of the window border. This patch makes
sure that each time the status of the ok button is changed the window resizes
itself to the content.
Attachment #109951 - Attachment is obsolete: true

Comment 6

15 years ago
Comment on attachment 110270 [details] [diff] [review]
An improved patch

Matthew needs this reviewed and, if is is acceptable, checked in since he does
not have CVS access.
Attachment #110270 - Flags: first-review?(mikep)

Comment 7

15 years ago
Adding appropriate keywords and reassigning back to Mike.
Assignee: buckett → mikep
Keywords: patch, review

Comment 8

15 years ago
The patch seems to have been applied to version 1.71 of eventDialog.js in CVS
and the CVS version now seems to work. Should this bug be closed now?
(Assignee)

Comment 9

15 years ago
I've done some more work on the calendar event dialog.  This should be fixed in
CVS now.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Attachment #110270 - Flags: first-review?(mikep)
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.