this example works in IE, OmniWeb, iCab ---- but not Mozilla

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: ipolyi, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126

<FORM name=Dest>
<table border=0 width=30%><TH>
<INPUT type=button value=previous onClick='window.open(URL="d3.html","_top")'>
</TH><TH>
<INPUT type=button value=EXIT onClick='window.open(URL="d0.html","_top")'>
</TH><TH>
<INPUT type=button value=next onClick='window.open(URL="d5.html","_top")'>
</TH></TABLE>
</FORM>


Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
nothing happens

Expected Results:  
bring up desired page

I don't know whether I'm doing something not supported, but since my code works
in the other browsers, I thought I'd report it.
The first arg to window.open() is just a url string.  You're doing an assignment
there.  The reason this works in other browsers is that the result of the
assignment is a string. The reason it fails in Mozilla is that assigning to
"URL" finds the the URL property on the document and assigns to document.URL,
which throws an exception, since document.URL is readonly (see the JS console).

I think all of that behavior is correct, but to DOM0 for confirmation.
Assignee: asa → jst
Status: UNCONFIRMED → NEW
Component: Browser-General → DOM Level 0
Ever confirmed: true
OS: MacOS X → All
QA Contact: asa → desale
Hardware: Macintosh → All
Mass-reassigning bugs to dom_bugs@netscape.com
Assignee: jst → dom_bugs
Invalid.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.