Copying a link and then pasting into Composer or an e-mail pastes text and Anchor tag but not HREF

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: mozilla, Assigned: mozeditor)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20021126

Copying a link from content within the Browser or Composer and then pasting into
Composer or an e-mail message pastes the text and the Anchor tag but somehow
excludes the HREF, making the result appear as text instead of a link.

Reproducible: Always

Steps to Reproduce:
1. Browse to a web page or open a Composer page that has a link on it.
2. Select the link and copy it. You can use Control+C or the right-click menu.
3. In a Composer window or a new e-mail message, paste with either Control+V or
the right-click menu.

Actual Results:  
Only the text of the link and its style got pasted. If you pasted into Composer,
go to the Source tab and notice the Anchor tag around the text without the HREF.

Expected Results:  
As in Mozilla 1.1, pasting a link should have copied the HREF into the Anchor,
copying the link.

Mozilla 1.1 worked, but 1.2 does not. I have not yet tried this at home with Mac
OS X yet, so I might append to this bug later today.

No crash occurs during the reproduction of this bug.

I am using the Modern theme.

I am running Windows XP Professional with the latest patches and service packs.
Open applications include Mozilla 1.2's Mail, Palm Desktop, Symantec Norton
Antivirus, OpenOffice 1.0.1, and Apache HTTP Server 2.0.43.

Comment 1

16 years ago
-> composer
Assignee: jaggernaut → syd
Component: XP Toolkit/Widgets → Editor: Composer
QA Contact: jrgm → sujay
(Reporter)

Comment 2

16 years ago
I upgraded to Mozilla 1.2.1 and this issue went away! :-)

Before I upgraded, however, I noticed that copying styled text and pasting would
paste the <font> tag but forget the font name, points, style, etc -- just like
how pasted links forgot the HREF.

Whatever was fixed in 1.2.1 apparently fixed this bug, too, so it's probably
okay to mark this one as RESOLVED/WORKSFORME.

Thank you for making the world's most awesome, privacy-conscience, user-friendly
web browser, e-mail client, and application platform :-)!

Comment 3

16 years ago
-->core

Can someone try this in a more recent build to see if it has been fixed?  I
would be surprised if it hadn't been fixed (perhaps this is a dupe?)
Assignee: syd → jfrancis
Component: Editor: Composer → Editor: Core
(Assignee)

Comment 4

16 years ago
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.