Closed Bug 1831176 Opened 1 year ago Closed 11 months ago

Implement the newer GC cast encodings

Categories

(Core :: JavaScript: WebAssembly, task, P2)

task

Tracking

()

RESOLVED FIXED
117 Branch
Tracking Status
firefox117 --- fixed

People

(Reporter: bvisness, Assigned: bvisness)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

The encoding for br_on_cast has changed again to separate br_on_cast and br_on_cast_fail instead of relying on a flag bit. See https://github.com/WebAssembly/gc/pull/359#issuecomment-1531774122.

See Also: → 1827952, 1799713
Severity: -- → N/A
Priority: -- → P2
Duplicate of this bug: 1843633

The wasm GC br_on_cast and br_on_cast_fail instructions used to
share the same opcode and were disambiguated by a flag. They now
use two different opcodes.

Assignee: nobody → bvisness
Status: NEW → ASSIGNED

Updating wast to the latest version in order to get the new binary encoding for cast instructions.

Depends on D184021

Pushed by bvisness@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/59aa4c2eb8b3
Implement new GC cast encodings. r=yury
https://hg.mozilla.org/integration/autoland/rev/50de53b66856
Update wast crate. r=yury,glandium,supply-chain-reviewers
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 117 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: