If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

composer undo not available on first entering text

VERIFIED FIXED in mozilla1.3beta

Status

SeaMonkey
Composer
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Robert T. Drury, Assigned: Kathleen Brade)

Tracking

({regression, topembed})

Trunk
mozilla1.3beta
regression, topembed

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE-)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3a) Gecko/20021126
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3a) Gecko/20021126

In composer the undo command isn't available until a text selection is made. 
Undo should probably be enabled the first time new content is entered into the
document.


Reproducible: Always

Steps to Reproduce:
1. new composer window
2. type in some text

Actual Results:  
undo is not available

Expected Results:  
make undo available
(Assignee)

Comment 1

15 years ago
-->brade
Assignee: syd → brade
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1, regression
OS: Linux → All
Hardware: Other → All
Whiteboard: EDITORBASE
confirming. please note that ctrl-Z works and undoes the typing.

Comment 3

15 years ago
*** Bug 188209 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: nsbeta1 → nsbeta1+, topembed
Whiteboard: EDITORBASE → EDITORBASE-
(Assignee)

Comment 4

15 years ago
Created attachment 112177 [details] [diff] [review]
update undo commands when updating style commands
(Assignee)

Updated

15 years ago
Attachment #112177 - Flags: superreview?(kin)
Attachment #112177 - Flags: review?(sfraser)

Comment 5

15 years ago
Comment on attachment 112177 [details] [diff] [review]
update undo commands when updating style commands

sr=kin@netscape.com
Attachment #112177 - Flags: superreview?(kin) → superreview+

Comment 6

15 years ago
Comment on attachment 112177 [details] [diff] [review]
update undo commands when updating style commands

>+  // isn't this redundant with the UpdateCommandGroup above?
>+  // can we just nuke the above call?
>   UpdateCommandGroup(NS_LITERAL_STRING("style"));

It is redundant the way that command groups are used now, but may not be in the
future.

>       case "cmd_bold":
>         // Update all style items
>         window.updateCommands("style");
>+        window.updateCommands("undo");
>         break;

This "cmd_bold" case needs a comment to say that it's acting as a proxy for all
style commands.
Attachment #112177 - Flags: review?(sfraser) → review+
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.3beta
(Assignee)

Comment 7

15 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 8

15 years ago
Wouldn't it be more efficient to update the undo command when you open the menu?
vrfy'd fixed with 2003.02.19.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.