Closed Bug 183147 Opened 18 years ago Closed 11 years ago

Submenu closes when I navigate to it

Categories

(Firefox :: Bookmarks & History, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: andre, Assigned: p_ch)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

When I move my mouse into an open submenu and land on a new submenu the
currently open submenu closes. This does not occur if I land on a bookmark item.
I know that I land on the item because I can see it highlight for a short while
before disappearing. Furthermore, this does not happen *always*, often it works
the first few times, then breaks.

The problem does not occur if the subitem is the first one in the submenu,
because I then move my mouse horizontally. To navigate properly to submenus I'm
therefore forced to move my mouse horizontally then vertically, rather than
diagonally and directly to the subitem.

This problem does not occur in Mozilla (1.0.1).

Reproducible: Always

Steps to Reproduce:
WFM Mozilla/5.0 (Windows NT 5.0; en-US; rv:1.3a) Gecko/20021201 Phoenix/0.4
I was tempted to say WFM, but I think I've found a reproducible case.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021126 Phoenix/0.4

Look at http://www.perilith.com/~luser/phx-bookmarks.png

If I have the "Imported IE Favorites" folder open, then move down to "Java
Downloads" and then quickly over to "Links" the "Imported IE Favorites" menu
disappears.

Steps to reproduce:
1) Click on the "Bookmarks" menu
2) Select a bookmark folder to display the contents in a submenu (folder must
have another folder inside it)
3) Move your mouse down then right to the folder in the submenu

Expected result:
Folder in submenu should be highlighted.

Actual result:
Submenu closes.

It appears to happen only when the selected item in the submenu is a folder.  Is
this Phoenix-specific?  I don't have Mozilla here to test.
> It appears to happen only when the selected item in the submenu is a folder.

The above is crucial for the reprodtion of the bug.
If you pass over any item (folder or bookmark) while moving (diagonally) to the
submeny, and end ONLY pass over folders IN the submeny, the submeny will close.

Very obvious if you create a subfolder filled with only subfolders.

Definitly a bug.

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3a) Gecko/20021128 Phoenix/0.4
Confirming bug with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a)
Gecko/20021204 Phoenix/0.4
Status: UNCONFIRMED → NEW
Ever confirmed: true
-> all
letting in the phoenix component for now. Though it's not phoenix specific.
OS: Linux → All
Hardware: PC → All
Still exists in 0.6.1rc1, #2's comment is a good test case.

(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030725 Mozilla
Firebird/0.6)
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor
*** Bug 219182 has been marked as a duplicate of this bug. ***
I have been annoyed by this for some time.

IMHO the problem is that the top of the submenu is vertically aligned with the
top of the parent entry. If you move the mouse slightly up when selecting the
submenu disappears - this seems to happen to me quite often and is really
irritating.

Safari has solved the problem by allowing a small (3/4 pixel?) 'margin' above
the top of the submenu to allow for navigation innacuracy.

Please fix this, apart from being annoying, it discriminates against those with
less than perfect motor control.
I'm sorry, this is not at all obvious here. What are the specific steps to
reproduce? Please explain, from an empty bookmarks file, what bookmarks or
folders I need to create and how to nest them, then specifically how to move the
mouse to trigger this. Thanks.
I re-created the bug in Linux (Gentoo) and Windows XP.  It's more obvious in the
Linux version because the Bookmarks disappear quicker.

1. Go to Bookmarks
2. Scroll to a folder in Bookmarks (let's say "News")
3. If I do not move right quick enough to highlight a link or a sub-folder, the
Bookmark disappears.  It also occurs during the "moving to the right" procedure
when the cursor moves off from the "News" bookmark line, either moving slightly
up or down, the Bookmark disappears.
4. Same thing occurs if you are going to a sub-folder within a folder.  It
mostly has to do with moving the mouse cursor up or down slighly while going
right/left to a link/folder.

i only have this problem when using Compact Menu extensions tool bar button
[the phish and the text button]
I have encountered this problem in Mozilla Firefox 1.0 ... I thought I'd
describe the steps I use to reproduce this bug. It's really irritating me:

First, you must have the following available in the Bookmarks:

a) A submenu "A" under Bookmarks, within it at least one submenu "C" and one
bookmark "D".
b) Another submenu "B" under Bookmarks, that sits after the submenu "A" in the list.

Sometimes it helps to make more submenu b's and more submenus inside of submenu
a, just for manual dexterity reasons.

1) Click on "Bookmarks" menu. The main menu will open.
2) Hover over submenu "A" until it displays to the right.
3) Move the mouse down over submenu "B" and then right to submenu "C". You must
do this at a reasonable speed, or else submenu "A" will close by design.
However, even if you do this at a good speed, submenu "A" disappears. This, I
believe, is the bug.
4) Reset the experiment by hovering over the menu entry "Bookmarks".
5) Hover over submenu "A" until it displays to the right.
6) Move the mouse down over submenu "B" and then right to bookmark "D". Again,
you must do this at a reasonable speed or else submenu "A" will close by design.
In this case, submenu "A" does not disappear as it does in Step #3.

Hope this helps. I've tested this in Internet Explorer, and it doesn't have this
problem.
This bug was reported against the mozilla suite back in 2001:

https://bugzilla.mozilla.org/show_bug.cgi?id=66254

It would be really nice to see this fixed, it makes submenus much harder to use
than necessary.
I've read the comments, and I've realized how to reproduce the bug always.
There's  Bookmarks / submenu "A". 
Now, if you first do a plain horizontal movement quickly to the right, and click
on another submenu "B", it works good. The emphasis is on _first plain horizontal_.
However, if you're lazy, you take a shortcut - instead of first horizontally
moving the mouse, you take a shortcut, and go diagonally, move the mouse to the
bottom right. The submenu appears for a moment, but goes away right away.
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
This is WORKSFORME on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1b3pre) Gecko/20081210 Shiretoko/3.1b3pre
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.