Closed Bug 1831603 Opened 1 year ago Closed 1 year ago

Include more info in the mach-try-perf cache key to make it more unique

Categories

(Testing :: Performance, defect, P2)

defect

Tracking

(firefox115 fixed)

RESOLVED FIXED
115 Branch
Tracking Status
firefox115 --- fixed

People

(Reporter: sparky, Assigned: sparky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This bug is for adding more information to the mach try perf cache key. We should include the query being used in the cache key alongside the revision. This way future base pushes will be redone if the same tasks are not selected. This won't apply for --rebuild to try to keep the CI load lower.

This patch adds the selected task information to the cache file info so that we create a new base try run instead of using a cached one. The cache is also converted to use a list of base pushes that each may have unique tasks that were run.

Assignee: nobody → gmierz2
Status: NEW → ASSIGNED
Duplicate of this bug: 1831663
Pushed by gmierz2@outlook.com:
https://hg.mozilla.org/integration/autoland/rev/10105a750b50
Include tasks selected in the mach-try-perf cache entry. r=MyeongjunGo
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 115 Branch
Regressions: 1832976
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: