svelbland.de - Submenu appears in Moz 1.1 but doesn't appear in Moz 1.2.1 when clicked

RESOLVED FIXED

Status

Tech Evangelism Graveyard
German
--
major
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Jörg Büsse, Unassigned)

Tracking

({regression})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

When I click on Beach/Volleyball the Submenu doesn't appear. In previous
Versions till 1.1 it worked, as expected.

Sorry but I'am not the Author of this page, just a user.

Sorry for my english, I'm german.

Reproducible: Always

Steps to Reproduce:
1. goto www.svelbland.de
2. click on Beach-/Volleyball (left side)
Actual Results:  
The Menu extends but the Submenu Image doesn't appear (perhaps document.write ??)

Expected Results:  
What do you think ? Submenu with 4 Links (Halle ... Beach ...) should appear.

Comment 1

15 years ago
Also seing this with build 2002120104, Windows 2000
To views.  Looks like the page just sets a stupid clip on the menu divs (and we
fixed some bugs in the application of clip since 1.1).
Assignee: rogerl → roc+moz
Component: JavaScript Engine → Views
QA Contact: pschwartau → ian

Updated

15 years ago
Keywords: regression

Comment 3

15 years ago
regression between linux trunk builds 2002080508 and 2002080708
backing out bug 104321 fixed this bug

marking NEW
Depends on: 104321
Yeah, backing that out makes it so that clip is never set on the thing since
that bug fucks up our round-tripping of clip.

Comment 5

15 years ago
Created attachment 108154 [details]
testcase

the page appears to have trouble parsing the value of element.style.clip

click on "foo"
testcase output before regression:
--------------------
rect(0px 135px 20px 0px)
0, 135, 20, 0
35
----------------------
after regression
---------------------
rect(0px, 135px, 20px, 0px)
0,, 135,, 20,, 0
NaN

Updated

15 years ago
Keywords: testcase
Andrew, thanks!

The new output is the correct one (the one without commas is correct css, but
only due to some weird errata stuff).
Assignee: roc+moz → nitot
Status: UNCONFIRMED → NEW
Component: Views → Europe: West
Ever confirmed: true
Keywords: testcase
Product: Browser → Tech Evangelism
QA Contact: ian → brantgurganus2001
Version: Trunk → unspecified
So this is a wontfix?

And who is Tristan Nitot?
It's an evangelism bug and Tristan Nitot is the head European evangelist last I
checked.
Summary: Submenu appears in Moz 1.1 but doesn't appear in Moz 1.2.1 when clicked → svelbland.de - Submenu appears in Moz 1.1 but doesn't appear in Moz 1.2.1 when clicked
move...
Assignee: nitot → german
Component: Europe: West → German
QA Contact: brantgurganus2001 → german
(Reporter)

Comment 10

14 years ago
Site Code altered - Problem solved by Site Author
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.