Inconsistent switching to new tabs upon 'open in new tab' selection.

VERIFIED INVALID

Status

SeaMonkey
Tabbed Browser
--
minor
VERIFIED INVALID
15 years ago
10 years ago

People

(Reporter: Ian Graham, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; H010818; YComp 5.0.2.4)
Build Identifier: Mozilla 1.2.1

I have noticed that if I use the right mouse button to select 'open link in new 
tab' that the newly opened tab usually, but not always gets focus. Sometimes 
the frame I start from retains focus, and the tab is loaded in background.

Both behaviors are useful: the second is nice if you're browsing a page, and 
want to quickly open tabs for a number of links, and explore the links later. 

I don't know what the UI design called for, and can't find a pref to define 
this behavior.  

Reproducible: Sometimes

Steps to Reproduce:
1. Right click on a link in a document.
2. Select 'open link in new tab'
3. Observe whether or not the new tab takes focus, or not.



Expected Results:  
Seems that the behavior (new tabs take focus or not) should be a pref?

Comment 1

15 years ago
The preference is under
edit : preferences : navigator : tabbed browsing : load links in the background

If this is ticked, the tabs should not take the focus. Of course, if the pref
isn't being respected, this is still a valid bug (which I guess it is since it's
marked new).
(Reporter)

Comment 2

15 years ago
My stupid mistake .... I've checked and can't reproduce this. I believe it was
just me running different installed versions of Mozilla, each with different
setttings for that preference .... marking INVALID.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.