History last visited time is at GMT

RESOLVED WORKSFORME

Status

()

Core
History: Global
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Craig, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2) Gecko/20021126

The "last visited" date and time are displayed in GMT. Most humans don't work in
GMT and having to remember that some of today's history is under "today" and
some under "yesterday" is rather unintuitive.

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
Works for me in Mozilla 1.2.1 (build 20021130) on Windows NT. I'm in GMT+1 (CET)
and so is my history.

Are you sure you're not seeing bug 86615 ?
(Reporter)

Comment 2

15 years ago
The part about days is just the hardest part to use. Everything in history is
displaying as GMT for me. eg. This page itself has "Last Visited" being
"04/12/02 4:33:12". The actual time here was 4/12/02 15:33:12.

For what it's worth, the feedback agent displays times that are one hour out
(ie. seems to be ignoring daylight savings), so it's not consistent with that.

(Reporter)

Comment 3

15 years ago
Seeing same behaviour under Win98 with 1.3b.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030210
(Reporter)

Comment 4

15 years ago
Created attachment 115818 [details]
screenshot

Screenshot (with extraneous parts removed) showing real time 1:37pm, while
Mozilla history lists 2:36am for last page viewed.
(Reporter)

Comment 5

15 years ago
I've worked out what Mozilla is doing wrong.

Background: Back in the old days of MS-DOS, various Unix software was ported to
DOS. This can lead to unfortunate problems at user level due to design
differences in the underlying OS (or lack of OS, in DOS's case). Unix assumed
that the hardware clock was set to GMT and manipulated user input and output of
date values according to timezone settings. DOS had no idea of such things and
assumed that all hardware dates/times are according to local time.

For the sake of such DOS programs, settings such as "set TZ=EST0" in
autoexec.bat make sense.

When Windows came along, it provided for handling of timezones. Old DOS programs
that did their own timezone handling worked fine with TZ set, since Windows
programs don't take any notice of the value of TZ.

Well, at least, most Windows programs don't. Unfortunately, Mozilla actually
takes notice of TZ settings in autoexec.bat that are intended for old DOS
programs and uses it to override the actual settings in Windows! This is a
really bad idea. It's inconsistent with other Windows programs, even the
Netscape quality feedback agent included with Mozilla.

Comment 6

14 years ago
Does this problem exists in newer builds?

Comment 7

14 years ago
I cannot reproduce this problem in any current builds (mozilla or firefox) on
windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.