holding mouse down on scrollbar causes 100% cpu utilization

RESOLVED DUPLICATE of bug 141710

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 141710
16 years ago
16 years ago

People

(Reporter: Michael Vance, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2) Gecko/20021126

Just noticed this offhand while browing this morning: if I click and hold on a
scrollbar's slider widget, it pegs my CPU utilization at 100% according to
CeePeeYou, and about 60% user time according to top. I am using a 600 Mhz G3
640M iBook with OS 10.2.2.

This happens on other sites (cnn.com).

This happens with both main page scrolling and form UI elements (such as the one
in which I'm typing right now).

This does not happen in Chimera 0.6.

This does not happen on native UI widgets in other apps.

This does not happen on my Win2k machine running Moz 1.2.

This does not appear to happen to my friend running a PowerBook G4 with Mozilla
1.2 (anecdotally, I haven't seen it myself). Perhaps a system setup issue
somehow on my end?

Reproducible: Didn't try

Steps to Reproduce:
1. Load page with scroll bar
2. Click and hold on the grab widget in the scrollbar
3. Observe CPU utilization

Actual Results:  
CPU pegged at 100%.

Expected Results:  
CPU usage is unchanged relative to the Mozilla process.

Using the Modern theme.
(Reporter)

Comment 1

16 years ago
I just restarted Mozilla to test it and the problem still occurs.

Comment 2

16 years ago
similar/dup of bug 141710
(Reporter)

Comment 3

16 years ago
Agreed. I did search for other bugs, but was looking for keywords related to the
scrollbar, I didn't realize it was a general mouse issue.

*** This bug has been marked as a duplicate of 141710 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.