If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Javascript Error: uncaught exception: Permission denied to set property HTMLImageElement.src

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Brock Sides, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Test page displays broken image tags. Also, the page at
http://www.tnwd.uscourts.gov/index.asp does not display at all, and generates an
identical Javascript error in the console.

Reproducible: Always

Steps to Reproduce:
1. Open Javascript console.
2. Open either URL referenced above.
3.

Actual Results:  
On test page, broken image placeholder displayed. On www.tnwd.uscourts.gov, page
never renders due to Javascript error.

Expected Results:  
Show images on the test page. Display page at www.tnwd.uscourts.gov.
Sounds like you have the pref to disable setting src on an image set (look for
capability.policy prefs in your prefs.js).
(Reporter)

Comment 2

15 years ago
The following is set in C:\Program Files\mozilla.org\Mozilla\defaults\pref\all.js

pref("dom.disable_image_src_set", false);

No other .js file seems to have a relevant preference set.
Do you see the same problem if you create a new profile and run with that profile?

Comment 4

15 years ago
Setup a new fresh mozilla account, loaded the page into a winXP system same
build browser.

Site pages display correctly and worked OK, but the output from javascript
console had a whole lot of messages like this one ...

"Error: window.event has no properties
Source File: http://www.tnwd.uscourts.gov/Attorneys/Pro_Bono/webindex.html
Line: 18"

as I browsed around the site.

everything displayed correctly though.

bill
Mass-reassigning bugs.
Assignee: jst → dom_bugs

Comment 6

15 years ago
Reporter, using your URL ( .. uscourts.gov ) i get no javascript errors.

build:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

Could you try again with a current Mozilla-version 

Comment 7

14 years ago
WORKSFORME, no feedback from reporter
-
Reporter, if you see this problem in a recent build of Mozilla, feel free
to return and reopen the bug.

Marking WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.